summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin261401 -> 261413 bytes
-rw-r--r--dev-python/pycxx/Manifest4
-rw-r--r--dev-python/pycxx/metadata.xml3
-rw-r--r--dev-python/pycxx/pycxx-7.1.7.ebuild37
-rw-r--r--dev-python/pysvn/Manifest3
-rw-r--r--dev-python/pysvn/files/pysvn-1.9.18-tests-3.11.patch33
-rw-r--r--dev-python/pysvn/pysvn-1.9.18.ebuild66
-rw-r--r--dev-python/python-dotenv/Manifest2
-rw-r--r--dev-python/python-dotenv/metadata.xml1
9 files changed, 147 insertions, 2 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 7eefa9719c06..1d7afcfcfa66 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/pycxx/Manifest b/dev-python/pycxx/Manifest
index 6fdbe8517037..df62e4e49fd3 100644
--- a/dev-python/pycxx/Manifest
+++ b/dev-python/pycxx/Manifest
@@ -1,3 +1,5 @@
DIST pycxx-7.1.5.tar.gz 156343 BLAKE2B 099de7f88c19ec86aea67b503e6fbdc0df66bbdd3bdc0ff7f8ce77425be9486e6abebed8548f9ac764688a85e62cda77d3832f460e5678b4c07b1c6d2123b257 SHA512 0f980298739886d0c05ddd5ee23ebb234014b8276d811e62dc5b0a738666c6a011ad3f4aeeb7b1b404d8bff87dddfc30f68eec9c6bd13d5f262a2f7c53e273be
+DIST pycxx-7.1.7.tar.gz 156383 BLAKE2B 69a454615c9a7cdc57f4c357b9e3805821711bc48efb82e684da6066069ff0ee6af3b76911a705adb6f984969659441d331a8470061b514180ddf53f6494a33d SHA512 5439b2f72a7f04a628e7e93d093566654f3b4eafe78a7834005f86fb08e614f22f4d1fffb8d626e46cd56880ff7792e494ee3282b313ce668a7497d2bc1fbea9
EBUILD pycxx-7.1.5-r1.ebuild 916 BLAKE2B d81ef87e677e63cf27b7771240091a743e48384ac4339e16aa7a76af938f21ada1cccd3b5ab3d20ef144dcd524acf1167f138809dd4340f34dcfe1f8f851bbc4 SHA512 7ca22d46fd8646df4dc7e52836abe53d45561d2b5125d09e5ccf88b7b7f1c2e1a2a9205d656ee214ab096f8ddeb67454c17153c41f19403d0330ba2d8278ec29
-MISC metadata.xml 667 BLAKE2B 1d5c679b2fcac7f5f302c35517f3903e0b3e3fdf5b65ec0005e0f1b2137ebc2a2e175031100c1bca997a6b2d7aa20ce3642c5dfcd7245c607d70d57b890694fe SHA512 2dc5bce4a24791956ca064750f7998556796af5afdb8cb24eaacd1e6485e6b92c939f053e410507e3fe3d6c29e320061c897f8ea0972ba04e4ed46f60876663c
+EBUILD pycxx-7.1.7.ebuild 990 BLAKE2B 8166b78459474a99d04e1c85243dd251de2ec5d513e56aec7e644153761d44825881d2984900d350892a2d973c36b4522a65b458b69182d0827de3a70745e4ff SHA512 9f805c8445f68f6ab106f3a6ce4f1888a63fa344b28d46ca2f2d6f61440ea48700628bc0890a5adab346aefb2b1ae4faba5da3a2ba085f0aa387b4673d3da601
+MISC metadata.xml 741 BLAKE2B 0704aeaef1fff687aa8374876e9d275a135d4ead7fabc938d8b3dc60954717fcf01bb79e8e9a72483184b13441d65294f41f7b5b0b19bebbf42c0934993723f4 SHA512 0b4f912fa2e38882bcaecede459f34270dd222a94bf70fa019e8de1eb1097c9c9016405b9b8a7933fd7839f11404a18c5e2ce7d4b4336a7121e86605903a8901
diff --git a/dev-python/pycxx/metadata.xml b/dev-python/pycxx/metadata.xml
index 0de8867fa9b6..898c29b01984 100644
--- a/dev-python/pycxx/metadata.xml
+++ b/dev-python/pycxx/metadata.xml
@@ -11,6 +11,9 @@
</longdescription>
<upstream>
<remote-id type="sourceforge">cxx</remote-id>
+ <!--
+ Note, PyCXX is not on PyPI, this is a *different* project:
<remote-id type="pypi">pycxx</remote-id>
+ -->
</upstream>
</pkgmetadata>
diff --git a/dev-python/pycxx/pycxx-7.1.7.ebuild b/dev-python/pycxx/pycxx-7.1.7.ebuild
new file mode 100644
index 000000000000..49ffda406c9a
--- /dev/null
+++ b/dev-python/pycxx/pycxx-7.1.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PYTHON_COMPAT=( python3_{8..11} )
+# DISTUTILS_USE_PEP517=setuptools broken, installs files to /usr/CXX
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="Set of facilities to extend Python with C++"
+HOMEPAGE="http://cxx.sourceforge.net"
+SRC_URI="mirror://sourceforge/cxx/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="doc examples"
+
+python_prepare_all() {
+ # Without this, pysvn fails.
+ # Src/Python3/cxxextensions.c: No such file or directory
+ sed -e "/^#include/s:Src/::" -i Src/*.{c,cxx} || die "sed failed"
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( Doc/. )
+ if use examples ; then
+ docinto examples
+ dodoc -r Demo/Python{2,3}/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pysvn/Manifest b/dev-python/pysvn/Manifest
index 293b07b8ae5e..1bda24b8b050 100644
--- a/dev-python/pysvn/Manifest
+++ b/dev-python/pysvn/Manifest
@@ -1,3 +1,6 @@
+AUX pysvn-1.9.18-tests-3.11.patch 1031 BLAKE2B 3886df331cbacedb7046b78a914b29cd65dd52854a12eeed91a83cd18997d2d8887ab099576b35f98f200d5a4bb726b38f155b9df36b7f8d676dd470962a6012 SHA512 ec1e83e905f0e1e0666e01d8cdf688c0fc04cef4a4e222b92abcdf777f7ed7884c68a742676cdc2f4642731d5d0a8abc5ca01f0fbf8c68a2a8b481726c22d858
DIST pysvn-1.9.15.tar.gz 667161 BLAKE2B 35e9e0967d5c0b4cebf546e40df17b66c66406d0f8100c32e6e840220f60b0083c0ed3f3af5f54e2264d06905ea90970d6b7cbfad2bab872a14d5d4aea5900df SHA512 0809507134fd31f6bcc90217e7840eb166e2eb2ed56316010a549dd70f6f855599f596942574343cdefd5997947b12c847df2cd145669f50aa93f603e46a5ee0
+DIST pysvn-1.9.18.tar.gz 667827 BLAKE2B cd32b4ec55118becd496a9aab6f4dd2b9d57c82e12d5a08b18d36d0caffbafe7066ff45c9493a36499979e759d38dd6b15a68e7bb5819464362c2691e7599160 SHA512 0ca2924223cdc5f29e961e879db6b0f88e82b5c4c40df50169468dd5a72cbccddea9f0d1680ef4a54d45e89b4b2b2c3c22f5e76c66196783a89cac8b583b6623
EBUILD pysvn-1.9.15-r1.ebuild 1272 BLAKE2B d2ba9aca8484b8006bd6a1c2fd76995123b0e99070817585ba6013261924091c9ec0bbc2932a69e8aa88647a4b885e2444e7b40983e03d497096b709cd98b767 SHA512 1890856b74902478cd993e40034998f4a9e61528f420ee88877a0210474f6f77119189348764dfa4c13a19f9f4510dd4c2737587fb0a78059c9cb9b119d8e9af
+EBUILD pysvn-1.9.18.ebuild 1286 BLAKE2B 44702fb081011d73eb345d1c0fe651848070119f6a093a6b4561342bdcdf8e5643f8b32590a4cc126c625540858da8cf2b07c8fcea97a9ee9f3b7350e8b95354 SHA512 f736fc2540d63169831cc67c5de8ea97be4a62e0674ebb52e5962045f734f7c8400d7290a32cafa5376acd31be43fbb7be2d15dd088f236a60b80b28874f3338
MISC metadata.xml 168 BLAKE2B 2e0e000b4c3b6ca04c12903fdbe278415c05a822623c52e9aa95cbbf3d50bcb1246b7edbda7d2f6b559af8950c6374e6e0a69b76319964cfe686bf50b0604a57 SHA512 4dcf45d1809e8390a2d8155c8ebfe0dd610203e392aeab0ccd8a10f42cc8532a4925eff32b35e7a6c35598a4efd288229034ec0732299dbd8cfa0acff705fed3
diff --git a/dev-python/pysvn/files/pysvn-1.9.18-tests-3.11.patch b/dev-python/pysvn/files/pysvn-1.9.18-tests-3.11.patch
new file mode 100644
index 000000000000..06a0bec16720
--- /dev/null
+++ b/dev-python/pysvn/files/pysvn-1.9.18-tests-3.11.patch
@@ -0,0 +1,33 @@
+From 0f4a2071dfeb90357a3eba947d6dd7cc879675ce Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Tue, 29 Nov 2022 01:08:49 +0100
+Subject: [PATCH] Examples/Client/svn_cmd.py: Stop DeprecationWarning from
+ breaking tests with Python 3.11
+
+---
+ Examples/Client/svn_cmd.py | 9 ++++++++-
+ 1 file changed, 8 insertions(+), 1 deletion(-)
+
+diff --git a/Examples/Client/svn_cmd.py b/Examples/Client/svn_cmd.py
+index 42e4c87..b8ef4ff 100644
+--- a/Examples/Client/svn_cmd.py
++++ b/Examples/Client/svn_cmd.py
+@@ -72,7 +72,14 @@ def initLocale():
+ locale.setlocale( locale.LC_ALL, '' )
+
+ else:
+- language_code, encoding = locale.getdefaultlocale()
++ import warnings
++
++ with warnings.catch_warnings():
++ if sys.version_info >= (3, 11):
++ warnings.filterwarnings("ignore", category=DeprecationWarning)
++
++ language_code, encoding = locale.getdefaultlocale()
++
+ if language_code is None:
+ language_code = 'en_GB'
+
+--
+2.38.1
+
diff --git a/dev-python/pysvn/pysvn-1.9.18.ebuild b/dev-python/pysvn/pysvn-1.9.18.ebuild
new file mode 100644
index 000000000000..ebc6f2e8f2cf
--- /dev/null
+++ b/dev-python/pysvn/pysvn-1.9.18.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Object-oriented python bindings for subversion"
+HOMEPAGE="https://pysvn.sourceforge.io/"
+SRC_URI="mirror://sourceforge/project/pysvn/pysvn/V${PV}/${P}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="doc examples"
+
+DEPEND="
+ >=dev-python/pycxx-7.0.2[${PYTHON_USEDEP}]
+ >=dev-vcs/subversion-1.9"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.9.18-tests-3.11.patch
+)
+
+python_prepare_all() {
+ # Don't use internal copy of dev-python/pycxx.
+ rm -r Import || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure() {
+ cd Source || die
+ CC="$(tc-getCC)" CCC="$(tc-getCXX)" \
+ esetup.py configure
+}
+
+python_compile() {
+ cd Source || die
+ emake
+}
+
+python_test() {
+ cd Tests || die
+ emake
+}
+
+python_install() {
+ cd Source || die
+ python_domodule pysvn
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( Docs/. )
+ if use examples; then
+ docinto examples
+ dodoc -r Examples/Client/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/python-dotenv/Manifest b/dev-python/python-dotenv/Manifest
index d0570556fd09..52e6c38dc13f 100644
--- a/dev-python/python-dotenv/Manifest
+++ b/dev-python/python-dotenv/Manifest
@@ -1,3 +1,3 @@
DIST python-dotenv-0.21.0.tar.gz 34984 BLAKE2B 5b2ac96e2c68afe04ec5e63da44c7109c0d142e1abad64fb9d4c87cfc84f36e62023854f72145f6a7f6b7e05bf58a57ee4b97ac8b84aa1304ddffba0a8795c6c SHA512 618335ad11a1ed8011d7cd0c6a83912b5cc29eddeb967c9594af32c6229ca178b571b08836776661612015ac9cd6753de1935f3f3e0e3b8feb733eccfbb262e7
EBUILD python-dotenv-0.21.0.ebuild 897 BLAKE2B 8098b08dc386cf9fd919cd56ae88e95dee672ef864333a54999e86ce5c380f2f90a82e838d8eb07797b775bc663b486e97761e8bc962468d9d4d37e8d0498116 SHA512 a60651fbdc8d84a5d2e059e11a79a225eeded4da59bb8f4c0aeacc5050877cff556411d21d552a48a7f399dbd0c1e71b9f24e5a9592d1d7a615f6583193b764b
-MISC metadata.xml 466 BLAKE2B 2e6368e01f6c9d9ab8e69a62196a10765ebc30365a3c2fab3e171386c7f26adcb93e7e4d0796696e531db66236c2c7f31b6c948a76682ff385993cc5504eba00 SHA512 45b35de8b5108267b28a1d6975824440d821cfe3e3a1c99dcadbe8d64b4ef78feadb9b0b7434c7292250e7f4615c13f2f37d5b5d41956d136f9bf25d175c356a
+MISC metadata.xml 529 BLAKE2B 1dd381879887df2d49a80084ffd386891cffa2547fedf00bb1dbee3c3abe79759620b606a916d71cab518bb3869ecee4775c735db22aac17e785bdda5c4905a5 SHA512 ad2129cb6c691f9f4622de92701f9825cbbfe61e9c2552f91bae53c90e19abe9b4f7cd2e379c516254d8b9a5989d4861f5ec05ec7949c5b533c9b7fc6416056a
diff --git a/dev-python/python-dotenv/metadata.xml b/dev-python/python-dotenv/metadata.xml
index 6dc4f6dbff6e..d23104e3b0f6 100644
--- a/dev-python/python-dotenv/metadata.xml
+++ b/dev-python/python-dotenv/metadata.xml
@@ -11,6 +11,7 @@
</maintainer>
<stabilize-allarches/>
<upstream>
+ <remote-id type="github">theskumar/python-dotenv</remote-id>
<remote-id type="pypi">python-dotenv</remote-id>
</upstream>
</pkgmetadata>