summaryrefslogtreecommitdiff
path: root/dev-python/zipp/zipp-2.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zipp/zipp-2.0.1.ebuild')
-rw-r--r--dev-python/zipp/zipp-2.0.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/zipp/zipp-2.0.1.ebuild b/dev-python/zipp/zipp-2.0.1.ebuild
new file mode 100644
index 000000000000..49ed0fc97eee
--- /dev/null
+++ b/dev-python/zipp/zipp-2.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+# [options.entry_points] is present in setup.cfg but it is empty
+DISTUTILS_USE_SETUPTOOLS=manual
+
+inherit distutils-r1
+
+DESCRIPTION="Backport of pathlib-compatible object wrapper for zip files"
+HOMEPAGE="https://github.com/jaraco/zipp"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/more-itertools[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-3.4.2[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )
+"
+
+distutils_enable_sphinx docs \
+ ">=dev-python/jaraco-packaging-3.2" \
+ ">=dev-python/rst-linker-1.9"
+
+distutils_enable_tests pytest