summaryrefslogtreecommitdiff
path: root/dev-python/yarl/yarl-1.7.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/yarl/yarl-1.7.2.ebuild')
-rw-r--r--dev-python/yarl/yarl-1.7.2.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/yarl/yarl-1.7.2.ebuild b/dev-python/yarl/yarl-1.7.2.ebuild
deleted file mode 100644
index c30d1180c9bf..000000000000
--- a/dev-python/yarl/yarl-1.7.2.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="Yet another URL library"
-HOMEPAGE="https://github.com/aio-libs/yarl/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
-
-RDEPEND="
- >=dev-python/multidict-4.0[${PYTHON_USEDEP}]
- >=dev-python/idna-2.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/typing-extensions-3.7.4[${PYTHON_USEDEP}]
- ' pypy3)
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs \
- dev-python/alabaster
-
-python_test() {
- cd tests || die
- epytest --override-ini=addopts=
-}