summaryrefslogtreecommitdiff
path: root/dev-python/yara-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/yara-python')
-rw-r--r--dev-python/yara-python/Manifest2
-rw-r--r--dev-python/yara-python/yara-python-4.4.0.ebuild41
2 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/yara-python/Manifest b/dev-python/yara-python/Manifest
index 90c59fd3696f..1a63092cd5d2 100644
--- a/dev-python/yara-python/Manifest
+++ b/dev-python/yara-python/Manifest
@@ -1,6 +1,4 @@
-DIST yara-python-4.4.0.gh.tar.gz 39295 BLAKE2B 27aa6b9fdf07cf30ec30a69c523e8a4eede52389a5565b4b083ac5d7206deaf3bcc0e2cf2fbda2fd01fce53b7ebc65e7c357705bc3244bfcc004bce2acd44e9e SHA512 8c6e30929172942e6e367c889f2d141f81264d9cfc4b5f5f4d35207d4ae25393050c976db823ef74f341ac18b7ee9eef8007d88348bc79848311d4b95fb1fdbd
DIST yara-python-4.5.0.gh.tar.gz 39301 BLAKE2B 9bee247ef21b6e2e576acbac7cfcf140fd3b1ab992affc019f9ce290e00809e397d5057b9033f53fcd94885e855e783e4c43835850c9e6dcd57d74661ba8380b SHA512 b4f091bff7fd3bcd63e7f9f0a765aac7bdb3f17a1bc4b163687ae9ca21048194d90cf2bf1165998edb9953b83e022939179c51de59862a456676f099de69778d
-EBUILD yara-python-4.4.0.ebuild 910 BLAKE2B abf64728f618945644db1b9dabc04c882a24571f05a1416c7344df5ea9c4d5b2680d6857726fd1e5640114ca1fd8f57576ef432bc3bf31a90e6c6f9cae185e35 SHA512 ea4bba09165f4bf3b98b4b97326fa8e7e46ba42e3f972283bad11f0a38a11dd5df776a50e2d2cb45d34dbd02806ac2f339225d3641efe9afe7e9c7c5bd0c486c
EBUILD yara-python-4.5.0.ebuild 910 BLAKE2B abf64728f618945644db1b9dabc04c882a24571f05a1416c7344df5ea9c4d5b2680d6857726fd1e5640114ca1fd8f57576ef432bc3bf31a90e6c6f9cae185e35 SHA512 ea4bba09165f4bf3b98b4b97326fa8e7e46ba42e3f972283bad11f0a38a11dd5df776a50e2d2cb45d34dbd02806ac2f339225d3641efe9afe7e9c7c5bd0c486c
EBUILD yara-python-9999.ebuild 912 BLAKE2B 3939e8490e8854e4e64880afb8b9338b05a3b2fb7b71d3b8468b45b4e19270e5ad898006188405ef24da7a42026f7d18a6468225686d85a9d67a31d9e345647e SHA512 78c27faf6554db4176aa524eb249a6eb2c0d63ecc08f07bd8ed7190c2016c986c1d9c2c0c9456b78bf13a6f18629e35c9480888ee3c63fc456e835504398ffa0
MISC metadata.xml 868 BLAKE2B 45f55060dbf7936f5004b8b6b9332ae01fbe8f25c008d6b272245ae3a21522ffdb1b3d11a338fdf31300aa274c4e24cd05ecdc62ad0b1e757188edf174c6e27e SHA512 ab67d86f6deb877d1f5a22ec36e381d7cdf62ec0634dbfd526ea2b58a5e4b9d6d6e2f06ead9cf7e8d4cff463bdd3486992350d94715d7b59c40c746ad9184e22
diff --git a/dev-python/yara-python/yara-python-4.4.0.ebuild b/dev-python/yara-python/yara-python-4.4.0.ebuild
deleted file mode 100644
index bde11ea7577c..000000000000
--- a/dev-python/yara-python/yara-python-4.4.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-DISTUTILS_EXT=1
-PYTHON_COMPAT=( python3_{10..12} )
-inherit distutils-r1
-
-DESCRIPTION="Python interface for a malware identification and classification tool"
-HOMEPAGE="https://github.com/VirusTotal/yara-python"
-
-if [[ ${PV} == "9999" ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/VirusTotal/yara-python.git"
-else
- SRC_URI="https://github.com/virustotal/yara-python/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
- KEYWORDS="amd64 ~arm64 ~ppc64 x86"
-fi
-
-LICENSE="Apache-2.0"
-SLOT="0"
-
-RDEPEND="
- =app-forensics/yara-$(ver_cut 1-2)*
-"
-DEPEND="${RDEPEND}"
-
-distutils_enable_tests unittest
-
-python_configure_all() {
- cat >> setup.cfg <<-EOF
- [build_ext]
- dynamic_linking = True
- EOF
-}
-
-python_test() {
- "${EPYTHON}" tests.py || die "Tests fail with ${EPYTHON}"
-}