summaryrefslogtreecommitdiff
path: root/dev-python/yamlpath
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/yamlpath')
-rw-r--r--dev-python/yamlpath/Manifest3
-rw-r--r--dev-python/yamlpath/metadata.xml18
-rw-r--r--dev-python/yamlpath/yamlpath-3.8.0.ebuild54
3 files changed, 0 insertions, 75 deletions
diff --git a/dev-python/yamlpath/Manifest b/dev-python/yamlpath/Manifest
deleted file mode 100644
index 220cbf1f3b80..000000000000
--- a/dev-python/yamlpath/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST yamlpath-3.8.0.gh.tar.gz 227377 BLAKE2B 9a722a6f637144a8085c7b71c8ac0c966d2ff7eda7b7136614db06406024c21cdbf6b30d3a5cc7b78ba8e268d406c0db15f15130098b680a1ce36a6eb8d31b9c SHA512 8a91c1519a7a93b099c77d2f850dc775c0ca8147d3ea4eb96408bb3f53a102301c6a9b6d1c5c47580a59f701e8316ff49e27d4643c21c8bc87fb337e6982e91f
-EBUILD yamlpath-3.8.0.ebuild 1120 BLAKE2B 135fc3c69e2bae9de6765cbe95459d80dc3f47863802c57a0190e7138613f9fd45f73a3994678cfae9c2a9338008d6a815c2fafb1c7cb9c2edc01449c7a1f2f7 SHA512 5ac6f83b72c71088f2baf503b595fdf13c6e460cbc0a020ab50279ae3205b1e165b581601002c0204e9d84cc3f682f05d45037d3afd225efedd58e6541f61bc7
-MISC metadata.xml 664 BLAKE2B cdf919f6a46dbc7ed8f2546509a623e0e784da711afaade20ec79b2861e8c83f54f755ce68ec2944bd0edb92f2e05b18a9c0ff93430c185574c41de2d789e03d SHA512 8020ca58f464e2aed71c01c29375b95dda238be6cdb94468a0abe50c7ce0270a42d723318f34cb4eb8728184cbe6769c7e666f43cffde37e6e9f42cab4d7292e
diff --git a/dev-python/yamlpath/metadata.xml b/dev-python/yamlpath/metadata.xml
deleted file mode 100644
index b4a77c52d5a4..000000000000
--- a/dev-python/yamlpath/metadata.xml
+++ /dev/null
@@ -1,18 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <upstream>
- <bugs-to>https://github.com/wwkimball/yamlpath/issues</bugs-to>
- <changelog>https://raw.githubusercontent.com/wwkimball/yamlpath/master/CHANGES</changelog>
- <doc>https://github.com/wwkimball/yamlpath/wiki</doc>
- <remote-id type="pypi">yamlpath</remote-id>
- <remote-id type="github">wwkimball/yamlpath</remote-id>
- </upstream>
- <maintainer type="person">
- <email>zmedico@gentoo.org</email>
- </maintainer>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
-</pkgmetadata>
diff --git a/dev-python/yamlpath/yamlpath-3.8.0.ebuild b/dev-python/yamlpath/yamlpath-3.8.0.ebuild
deleted file mode 100644
index ad955b668138..000000000000
--- a/dev-python/yamlpath/yamlpath-3.8.0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Command-line processors for YAML/JSON/Compatible data"
-HOMEPAGE="
- https://github.com/wwkimball/yamlpath/
- https://github.com/wwkimball/yamlpath/wiki
-"
-SRC_URI="
- https://github.com/wwkimball/yamlpath/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-python/ruamel-yaml[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- sed -i -e '/ruamel\.yaml/d' setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local EPYTEST_DESELECT=()
-
- if ! has_version "dev-ruby/hiera-eyaml"; then
- EPYTEST_DESELECT+=(
- tests/test_commands_eyaml_rotate_keys.py
- tests/test_commands_yaml_merge.py::Test_commands_yaml_merge::test_yaml_syntax_error
- tests/test_commands_yaml_paths.py::Test_yaml_paths::test_search_encrypted_values
- )
- fi
-
- epytest
-}