summaryrefslogtreecommitdiff
path: root/dev-python/xlsxwriter/xlsxwriter-1.4.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/xlsxwriter/xlsxwriter-1.4.5.ebuild')
-rw-r--r--dev-python/xlsxwriter/xlsxwriter-1.4.5.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/xlsxwriter/xlsxwriter-1.4.5.ebuild b/dev-python/xlsxwriter/xlsxwriter-1.4.5.ebuild
new file mode 100644
index 000000000000..c0f4419513c1
--- /dev/null
+++ b/dev-python/xlsxwriter/xlsxwriter-1.4.5.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+TAG=RELEASE_${PV}
+MY_P=XlsxWriter-${TAG}
+DESCRIPTION="Python module for creating Excel XLSX files"
+HOMEPAGE="https://github.com/jmcnamara/XlsxWriter"
+SRC_URI="
+ https://github.com/jmcnamara/XlsxWriter/archive/${TAG}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest