summaryrefslogtreecommitdiff
path: root/dev-python/xdoctest
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/xdoctest')
-rw-r--r--dev-python/xdoctest/Manifest2
-rw-r--r--dev-python/xdoctest/xdoctest-1.1.4.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/xdoctest/Manifest b/dev-python/xdoctest/Manifest
index ffd30e8ddd84..dbda9bab126a 100644
--- a/dev-python/xdoctest/Manifest
+++ b/dev-python/xdoctest/Manifest
@@ -1,3 +1,5 @@
DIST xdoctest-1.1.3.gh.tar.gz 227008 BLAKE2B dcda05cbbc692fe7dd7d6b49d92f980f997e3f5f7025406d2a26019f67486b2dc8f1657d9f8760e3034e6bed9f35d9dd7ab728a07a3e25596dab95327ecc8ba4 SHA512 5ee08f15bc01efee8be55c85aa259615bd433d9be02655ac48d7db93a72c5bf69f73562d7887e56836a74721b90517e797e5a128311438b22ace6f463ecf330d
+DIST xdoctest-1.1.4.gh.tar.gz 230110 BLAKE2B a096dea40a783b7a0366ba00ab29e8cbd5e2be61c04ed790839b56674851ff2a8ad27a99a2a2523bac6e4b28c752ca683d2634ef5fa7bfb17708d8a637b867ac SHA512 cd2df8a01be14b5b2dc195621028c09a139b6cf952a853dea6548b706314f109fa88e27be331135d46aff8ca980a1e48a16c4afdedd368718a83c91ffa02bd34
EBUILD xdoctest-1.1.3.ebuild 1074 BLAKE2B 8fee68f7ec2c6e213242757731e216091918af6ca76c56a5db3df4f0dd3cca8cf27b0ae16efc71dbbbd3ffbab813f7e0576fc451abdf3fb08196af969a496f3f SHA512 f13e9fe55bdf585da5e09b12c39eec01d4cb88ee87e31426704f75a748b4f349169cce687c3abacea793d081bd2e8814d390c6cc32533651b284bb7f578845e2
+EBUILD xdoctest-1.1.4.ebuild 1074 BLAKE2B 8fee68f7ec2c6e213242757731e216091918af6ca76c56a5db3df4f0dd3cca8cf27b0ae16efc71dbbbd3ffbab813f7e0576fc451abdf3fb08196af969a496f3f SHA512 f13e9fe55bdf585da5e09b12c39eec01d4cb88ee87e31426704f75a748b4f349169cce687c3abacea793d081bd2e8814d390c6cc32533651b284bb7f578845e2
MISC metadata.xml 483 BLAKE2B 9939d6ceb1a1f9130a61ea445055cb9c06e99d7d53130e7ff25773fa2f18990a357dff204637f4fcfe6397d49e62f872db8cd272f5abc0111046bab76e310b4a SHA512 12c385799c61bbf92b5936989e083545b0b1f858f396f4504cd6c6e27b1a99e81bf350ac6286c21b2e900c9962a5798da3c03cff75dd3c2e751f8a25ced64ed5
diff --git a/dev-python/xdoctest/xdoctest-1.1.4.ebuild b/dev-python/xdoctest/xdoctest-1.1.4.ebuild
new file mode 100644
index 000000000000..70d8909b5a6b
--- /dev/null
+++ b/dev-python/xdoctest/xdoctest-1.1.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="A rewrite of Python's builtin doctest module but without all the weirdness"
+HOMEPAGE="
+ https://github.com/Erotemic/xdoctest/
+ https://pypi.org/project/xdoctest/
+"
+SRC_URI="
+ https://github.com/Erotemic/xdoctest/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+# dev-python/nbformat-5.1.{0..2} did not install package data
+BDEPEND="
+ test? (
+ >=dev-python/nbformat-5.1.2-r1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+#distutils_enable_sphinx docs/source \
+# dev-python/autoapi \
+# dev-python/sphinx-rtd-theme
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ tests/test_pytest_cli.py::test_simple_pytest_import_error_cli
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdoctest.plugin
+
+ epytest --pyargs tests xdoctest
+}