summaryrefslogtreecommitdiff
path: root/dev-python/xdg/xdg-5.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/xdg/xdg-5.1.1.ebuild')
-rw-r--r--dev-python/xdg/xdg-5.1.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/xdg/xdg-5.1.1.ebuild b/dev-python/xdg/xdg-5.1.1.ebuild
new file mode 100644
index 000000000000..f690901578f6
--- /dev/null
+++ b/dev-python/xdg/xdg-5.1.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Implementation of the XDG Base Directory Specification in Python"
+HOMEPAGE="https://github.com/srstevenson/xdg/ https://pypi.org/project/xdg/"
+SRC_URI="
+ https://github.com/srstevenson/xdg/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# https://bugs.gentoo.org/773415
+RDEPEND="!dev-python/pyxdg"
+
+distutils_enable_tests pytest