summaryrefslogtreecommitdiff
path: root/dev-python/wurlitzer/wurlitzer-3.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/wurlitzer/wurlitzer-3.0.0.ebuild')
-rw-r--r--dev-python/wurlitzer/wurlitzer-3.0.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/wurlitzer/wurlitzer-3.0.0.ebuild b/dev-python/wurlitzer/wurlitzer-3.0.0.ebuild
new file mode 100644
index 000000000000..7a64cf34ebad
--- /dev/null
+++ b/dev-python/wurlitzer/wurlitzer-3.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Capture C-level stdout/stderr in Python"
+HOMEPAGE="
+ https://github.com/minrk/wurlitzer/
+ https://pypi.org/project/wurlitzer/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest test.py
+}