summaryrefslogtreecommitdiff
path: root/dev-python/wstools
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/wstools')
-rw-r--r--dev-python/wstools/Manifest3
-rw-r--r--dev-python/wstools/files/wstools-0.4.8-fix-py3.10.patch29
-rw-r--r--dev-python/wstools/wstools-0.4.8.ebuild19
3 files changed, 40 insertions, 11 deletions
diff --git a/dev-python/wstools/Manifest b/dev-python/wstools/Manifest
index 608c7f0eb796..72c5b75f6c0f 100644
--- a/dev-python/wstools/Manifest
+++ b/dev-python/wstools/Manifest
@@ -1,4 +1,5 @@
+AUX wstools-0.4.8-fix-py3.10.patch 932 BLAKE2B 48d67a79f12a35fd93e5e493f3f488055b7be491790a3bb9bc2e4e823c329d3eff2f1243b85e84d137f386e29cb32ffc1185d6dc632bcce62da9e3454d33231b SHA512 cd6a16c72a7b3a565add77ed07e7864e5085dacd22891113d30920f336fc92628d75adf46f5ce684b502a0a03a88220e37966eaddcd53ca06a6911a3c967edeb
AUX wstools-0.4.8-setup.patch 648 BLAKE2B e2c1cbcd8a1fda7fc9a606add1a0171bb87b58a93e65b02960d29d50b64bc46023596bdd46f4d8c063e7d06f74f734ae22c71ba751c87b99d90000f946f2daad SHA512 2dbbe6a4b9de7e79334d63e083358253249a73f5e37de71d62a2aa8f889bcc5f76e5842e505a161e08398c572b9cc71a259372a6cc7689206498085c12ff578f
DIST wstools-0.4.8.tar.gz 199688 BLAKE2B 3b5137dd135ec8f0e6d69f94275d45367e609adb9763624fcabb899f84c6215c2df26485dcf32d44d6683bd97cd00e2d283cf9096b6f58414f2eacd9e8b93a4a SHA512 0f86e91a2de7333aaf5a58558a715edd6a0cf97150f6d0cae4ecf8e0702648a98e610aa6d3295444079bd616656efcb2823ae7c02c5c3ffcb4789548ac40cd0a
-EBUILD wstools-0.4.8.ebuild 755 BLAKE2B db393ed12853309e83adf4b071caea88dbea3db6912e1d6a0b35cb9026d1b8d3712559633f65d4f9f664904e41b0ee0477bc8ce63662a91ea115e7879448d4c1 SHA512 36748ddc5b14fe1c85d72085688ca6ae864b4fa58b0e85074d4f5f6a0f735b725d8f0f1222dd19fdce439f8dc15aacc2d183b4517045c5e79bbd54b8787eb87c
+EBUILD wstools-0.4.8.ebuild 822 BLAKE2B bf2c734584ec582d4e8e3f99ded708defd575affbeb2b3d604d8c6132994b697a1b3c751d19e5093c0190a958b193f2330cfe5fd99b1a14f11a4bd80754b142c SHA512 8c369002ff292e187ed5a1978ae248bbbf5871cf0941b0e0bf38d81740e86c90d6caed400aa5465e1561ab41be1d204052bd4d36948fb3171da36ad9bdc31be2
MISC metadata.xml 405 BLAKE2B d69d3c4e1719405f04df6f365e85a006018c2901f07b60c5d14ec82c85ca8b976315cdc0c50d5afea0dbcaa433d688a8942214138d31e508787be95e94c135c2 SHA512 1048dfaeda9e0c1a2adb0d723efeafb6aad13d12aef2f5d88c5d23f5ede7b3aac3133272c87f2309dfe10022ac5e1ad4259b02aa37f5b4370fe3fcdb7054e2d9
diff --git a/dev-python/wstools/files/wstools-0.4.8-fix-py3.10.patch b/dev-python/wstools/files/wstools-0.4.8-fix-py3.10.patch
new file mode 100644
index 000000000000..4baf12faf570
--- /dev/null
+++ b/dev-python/wstools/files/wstools-0.4.8-fix-py3.10.patch
@@ -0,0 +1,29 @@
+From c0aa811a845e78c27ef949b4dbc82dfcd9c3da68 Mon Sep 17 00:00:00 2001
+From: Arthur Zamarin <arthurzam@gentoo.org>
+Date: Thu, 19 Aug 2021 22:27:48 +0300
+Subject: [PATCH] Fix import collections.abc for python 3.10
+
+Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
+---
+ wstools/Utility.py | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/wstools/Utility.py b/wstools/Utility.py
+index c1ccd65..f5f1453 100644
+--- a/wstools/Utility.py
++++ b/wstools/Utility.py
+@@ -33,7 +33,10 @@ try:
+ from UserDict import DictMixin # noqa
+ except ImportError:
+ from collections import UserDict
+- from collections import MutableMapping as DictMixin # noqa
++ try:
++ from collections.abc import MutableMapping as DictMixin # noqa
++ except ImportError:
++ from collections import MutableMapping as DictMixin # noqa
+
+ from .TimeoutSocket import TimeoutSocket, TimeoutError # noqa
+
+--
+2.33.0
+
diff --git a/dev-python/wstools/wstools-0.4.8.ebuild b/dev-python/wstools/wstools-0.4.8.ebuild
index edd464ea8651..d6450a8d82fc 100644
--- a/dev-python/wstools/wstools-0.4.8.ebuild
+++ b/dev-python/wstools/wstools-0.4.8.ebuild
@@ -3,9 +3,9 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="xml(+)"
-
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
DESCRIPTION="WSDL parsing services package for Web Services for Python"
@@ -15,17 +15,16 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="
- ${RDEPEND}
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+BDEPEND="
dev-python/pbr[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest-timeout[${PYTHON_USEDEP}] )
"
-PATCHES=( "${FILESDIR}"/${PN}-0.4.8-setup.patch )
+PATCHES=(
+ "${FILESDIR}/${P}-setup.patch"
+ "${FILESDIR}/${P}-fix-py3.10.patch"
+)
distutils_enable_tests pytest