summaryrefslogtreecommitdiff
path: root/dev-python/werkzeug
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/werkzeug')
-rw-r--r--dev-python/werkzeug/Manifest2
-rw-r--r--dev-python/werkzeug/werkzeug-3.0.4.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/werkzeug/Manifest b/dev-python/werkzeug/Manifest
index 6c4a5b3be385..d5cf295d2be4 100644
--- a/dev-python/werkzeug/Manifest
+++ b/dev-python/werkzeug/Manifest
@@ -1,4 +1,6 @@
AUX werkzeug-3.0.2-pytest-xprocess-1.patch 864 BLAKE2B ff18777cce9debbb39ae524a54912417a3d3bd46a54b4ba91322f9abe038b47e4091049f4e4ebb9bf5c0e661b0d88bea2d157b840d02d81442a323b222d840d2 SHA512 8208a0b6695d6079b0bf251bba8cf2c3c7fb89a37aadeb74c534e6c61a7455e71fb61ec6a44d2689a311e77d9d00302a7d2dafa449deb7d4e207038bd43ac372
DIST werkzeug-3.0.3.tar.gz 803342 BLAKE2B 8c47d3131abeb8ce2d92291e08b603152210c44c40156b5399d24b167d0a02daf6adbeafec43e8b33dff940271feec95e9333e637e825f511cd5d03686c1e02e SHA512 fc771c161b37a376a86930c29c8b8052f81fb869cedea8c3c83af1e8b1aba271358c918e3067f3b0ac6d4a1689c8c355bff410d521c73a1909fd0ffc90fee6c6
+DIST werkzeug-3.0.4.tar.gz 803966 BLAKE2B 56e992c61ed977a677ae4ca403adfb335457df2f096eed3589d74f5539282b144e70895e4d403c9fb72621bc145c91315fab0d3ddca5afcc0040c0e582cf05ec SHA512 40ca7a6c54ba5593a854d6fda6c6b0fed08f03aa970ac83c86aa16b434b6f24f204ca425a0fae3f42610ce6e7ff9220224cc927018a7181d673b48b71b848422
EBUILD werkzeug-3.0.3.ebuild 1718 BLAKE2B 8a23f6f4bc308b41590856d284587a4847a8b0ddec08218bbb2af2544b90aa9668b5a0db77bd777c30a43e6506dcd84fbe58197d4e4aac94c02c7a0de5c8bf5c SHA512 9f0fafcb807ff035fa5deca355606971e61701cac787b6d997d328a9dbfad42962f0b7981268e30b6a6f0e611f6e6ac28416c772e3e11356e9d826857d6f46cc
+EBUILD werkzeug-3.0.4.ebuild 1726 BLAKE2B 1f2d3abab5ec94b74a2bd67e49a24909ca3688cd6d77de1711544ddc2e77e0220dc2a8ce370215a4a0ab9a1f90e7cc29a27fcefc30229f0532c377dfd6ac3abb SHA512 79e829a83a9d90100eaef4cd509d078d0d54593d4d4d92c195f9a8a77cdbfb5a5080accc246cb3370a56d6494ff537352582094452a3e57d845267edaeda8334
MISC metadata.xml 392 BLAKE2B 59644e2ff4cdd9ce2db59e36b9b3ec6ce7b7a87186c962bc6b1fa1ef490c30e542b62e8739b059a679f843af79ee7c8b13099bcbefa7ae3102aa3f5d1bf7055c SHA512 a79201b2e92c427248a4448a9734321f955e5431c46e0e58ead2e06c31945309c20f7de76f80e80d4c81ffb45deb4837e1a415a4d2596b7644b01735120899dd
diff --git a/dev-python/werkzeug/werkzeug-3.0.4.ebuild b/dev-python/werkzeug/werkzeug-3.0.4.ebuild
new file mode 100644
index 000000000000..473febdad0b4
--- /dev/null
+++ b/dev-python/werkzeug/werkzeug-3.0.4.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Collection of various utilities for WSGI applications"
+HOMEPAGE="
+ https://palletsprojects.com/p/werkzeug/
+ https://pypi.org/project/Werkzeug/
+ https://github.com/pallets/werkzeug/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test-rust"
+
+RDEPEND="
+ >=dev-python/markupsafe-2.1.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/ephemeral-port-reserve[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xprocess-1[${PYTHON_USEDEP}]
+ >=dev-python/watchdog-2.3[${PYTHON_USEDEP}]
+ test-rust? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ )
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/pallets/werkzeug/issues/2875
+ "${FILESDIR}/${PN}-3.0.2-pytest-xprocess-1.patch"
+)
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # RequestRedirect class started incidentally being tested
+ # with pytest-8, though the test isn't prepared for that
+ # https://github.com/pallets/werkzeug/issues/2845
+ 'tests/test_exceptions.py::test_response_body[RequestRedirect]'
+ )
+ if ! has_version "dev-python/cryptography[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ "tests/test_serving.py::test_server[https]"
+ tests/test_serving.py::test_ssl_dev_cert
+ tests/test_serving.py::test_ssl_object
+ )
+ fi
+
+ # the default portage tempdir is too long for AF_UNIX sockets
+ local -x TMPDIR=/tmp
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p xprocess -p timeout tests
+}