summaryrefslogtreecommitdiff
path: root/dev-python/werkzeug
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/werkzeug')
-rw-r--r--dev-python/werkzeug/Manifest2
-rw-r--r--dev-python/werkzeug/werkzeug-2.2.3.ebuild64
2 files changed, 0 insertions, 66 deletions
diff --git a/dev-python/werkzeug/Manifest b/dev-python/werkzeug/Manifest
index 0fca66b96a38..1a6ceb7624f7 100644
--- a/dev-python/werkzeug/Manifest
+++ b/dev-python/werkzeug/Manifest
@@ -1,6 +1,4 @@
AUX werkzeug-2.3.4-iri-bytes.patch 2038 BLAKE2B 55fa8b29b1964017c1022bece78c692a18e062aec5e541f722d5604092662d79ccd9305bcb362d9a557a49d2e39cf417a2018341dffee8232a3b4a14acdfefc9 SHA512 e38e79d21b8e40de29bef81a626ec87aaeed57d511aefdead17744dd1b6dd88d3e2e55792577b2080c6fbc6fdbbd9094f53c0110d7256bbb9402f32d6f969754
-DIST werkzeug-2.2.3.gh.tar.gz 847768 BLAKE2B 7d0b891a2b15e4fc469c3d331cfb2565f452ae77f772f7ab8e6254aedd172f9115cd3ebd9c82e951ea7505c0e58d6b6f07fb643a8e87af505e04686cccf56cd4 SHA512 3968e663f67e41da5148a4aa1d8e047ffd88416fa8df665e359bbe87992e4e723e1c915eed59ae86b53dd18817e41cdcef059483bce7aa8ed7b388dd4add1482
DIST werkzeug-2.3.4.gh.tar.gz 833090 BLAKE2B e9d0134fa2a1355a2ef0df0f86cca6ea0f0a0c9b6ece98a6774ceab0a284c6a899e915688cb3e2e9f6192a7943cbcf20578d1e8f2f439dd8a9ab0f3d49361bcd SHA512 1e519fc88ac4438aa4dbd623ef8afc96a630df61d25a5a28154749f5c38593edefbb32163a632a5f38fa70d8cf2f1ae93633e54cfafe72d497ab70c99f9b2478
-EBUILD werkzeug-2.2.3.ebuild 1662 BLAKE2B 59159583aef75b5a349dfe04b8c688279109b672ec773f0507b065c8564e2e50ab04ef0b17c6597625fc8c23ae111cd0a93182b7249e75f36c8762d4a1e139fa SHA512 c6aa7b6b5c0c9eeb5fdab5917b7c30d969d4cbd5ffb47351687cb9df9110f269ca694e54d746d8eb2822dc3ec536b80d577f60ed8794036c8c00072216768555
EBUILD werkzeug-2.3.4-r1.ebuild 1768 BLAKE2B 0ff8d994ff47a5fbb44556656c1e320d0145c1edb35614320502b65a9a3ad44ff896696d27784a777b9e92f8d39655f3044ab04ec319a45320a51fbbba0dfdac SHA512 14be7cdeb0697d9a8aad107da9d503be4c52978b225b78000d6cd0eea61ddb708831166ce45283cdc4598018553e316d19c3474b5574fab1a8f1cc678f658b7b
MISC metadata.xml 368 BLAKE2B 81932229098620395623f9149ac974f19fae9b65ad09943ee5c5d8d03c1e37e76061291c959fe5f004f531a244b3bb335c2a43dd66949c0be43493e45674d0e3 SHA512 67e5b5fea8052c0723820125271ea031ad984e0fe2af21d2423fc559bdc51dfe1d40f2fa5fe11e6d2b8b32216e716900080b859aad146c079ad2b390dd9844cf
diff --git a/dev-python/werkzeug/werkzeug-2.2.3.ebuild b/dev-python/werkzeug/werkzeug-2.2.3.ebuild
deleted file mode 100644
index 7e2db22b86dc..000000000000
--- a/dev-python/werkzeug/werkzeug-2.2.3.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Collection of various utilities for WSGI applications"
-HOMEPAGE="
- https://palletsprojects.com/p/werkzeug/
- https://pypi.org/project/Werkzeug/
- https://github.com/pallets/werkzeug/
-"
-SRC_URI="
- https://github.com/pallets/werkzeug/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="test-rust"
-
-RDEPEND="
- >=dev-python/markupsafe-2.1.1[${PYTHON_USEDEP}]
-"
-# NOTE: remove the loong mask after greenlet gains support for loong
-# see https://github.com/python-greenlet/greenlet/pull/257
-BDEPEND="
- test? (
- dev-python/ephemeral-port-reserve[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/pytest-xprocess[${PYTHON_USEDEP}]
- dev-python/watchdog[${PYTHON_USEDEP}]
- test-rust? (
- dev-python/cryptography[${PYTHON_USEDEP}]
- )
- !hppa? ( !ia64? ( !loong? (
- $(python_gen_cond_dep '
- dev-python/greenlet[${PYTHON_USEDEP}]
- ' python3_{8..10})
- ) ) )
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=()
- if ! has_version "dev-python/cryptography[${PYTHON_USEDEP}]"; then
- EPYTEST_DESELECT+=(
- "tests/test_serving.py::test_server[https]"
- tests/test_serving.py::test_ssl_dev_cert
- tests/test_serving.py::test_ssl_object
- )
- fi
-
- # the default portage tempdir is too long for AF_UNIX sockets
- local -x TMPDIR=/tmp
- epytest -p no:django -p no:httpbin tests
-}