summaryrefslogtreecommitdiff
path: root/dev-python/websockets/websockets-9.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/websockets/websockets-9.0.ebuild')
-rw-r--r--dev-python/websockets/websockets-9.0.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/websockets/websockets-9.0.ebuild b/dev-python/websockets/websockets-9.0.ebuild
new file mode 100644
index 000000000000..0992a9e2d617
--- /dev/null
+++ b/dev-python/websockets/websockets-9.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for building WebSocket servers and clients in Python"
+HOMEPAGE="https://websockets.readthedocs.io/"
+SRC_URI="https://github.com/aaugustin/${PN}/archive/${PV}.tar.gz -> ${P}-src.tar.gz"
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+
+distutils_enable_tests unittest