summaryrefslogtreecommitdiff
path: root/dev-python/websocket-client/websocket-client-1.5.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/websocket-client/websocket-client-1.5.1.ebuild')
-rw-r--r--dev-python/websocket-client/websocket-client-1.5.1.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/websocket-client/websocket-client-1.5.1.ebuild b/dev-python/websocket-client/websocket-client-1.5.1.ebuild
deleted file mode 100644
index 3d46ebd70e83..000000000000
--- a/dev-python/websocket-client/websocket-client-1.5.1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( pypy3 python3_{9..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="WebSocket client for python with hybi13 support"
-HOMEPAGE="
- https://github.com/websocket-client/websocket-client/
- https://pypi.org/project/websocket-client/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="examples"
-
-BDEPEND="
- test? (
- dev-python/python-socks[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests unittest
-
-python_install_all() {
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- dodoc -r examples
- fi
- distutils-r1_python_install_all
-}