summaryrefslogtreecommitdiff
path: root/dev-python/websocket-client/websocket-client-1.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/websocket-client/websocket-client-1.2.1.ebuild')
-rw-r--r--dev-python/websocket-client/websocket-client-1.2.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/websocket-client/websocket-client-1.2.1.ebuild b/dev-python/websocket-client/websocket-client-1.2.1.ebuild
new file mode 100644
index 000000000000..a0de1e2f73a9
--- /dev/null
+++ b/dev-python/websocket-client/websocket-client-1.2.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="WebSocket client for python with hybi13 support"
+HOMEPAGE="https://github.com/websocket-client/websocket-client"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+BDEPEND="
+ test? (
+ dev-python/python-socks[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}