summaryrefslogtreecommitdiff
path: root/dev-python/websocket-client/websocket-client-1.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/websocket-client/websocket-client-1.1.1.ebuild')
-rw-r--r--dev-python/websocket-client/websocket-client-1.1.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/websocket-client/websocket-client-1.1.1.ebuild b/dev-python/websocket-client/websocket-client-1.1.1.ebuild
new file mode 100644
index 000000000000..73166b2954d2
--- /dev/null
+++ b/dev-python/websocket-client/websocket-client-1.1.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="WebSocket client for python with hybi13 support"
+HOMEPAGE="https://github.com/websocket-client/websocket-client"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
+IUSE="examples"
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}