summaryrefslogtreecommitdiff
path: root/dev-python/websocket-client/websocket-client-0.40.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/websocket-client/websocket-client-0.40.0.ebuild')
-rw-r--r--dev-python/websocket-client/websocket-client-0.40.0.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-python/websocket-client/websocket-client-0.40.0.ebuild b/dev-python/websocket-client/websocket-client-0.40.0.ebuild
deleted file mode 100644
index 29e8e7ae2067..000000000000
--- a/dev-python/websocket-client/websocket-client-0.40.0.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1 vcs-snapshot
-
-MY_PN=${PN//-/_}
-
-DESCRIPTION="WebSocket client for python with hybi13 support"
-HOMEPAGE="https://github.com/liris/websocket-client"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="examples"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/backports-ssl-match-hostname[${PYTHON_USEDEP}]' 'python2*' )
-"
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( examples/. )
-
- distutils-r1_python_install_all
-}