summaryrefslogtreecommitdiff
path: root/dev-python/weasyprint
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/weasyprint')
-rw-r--r--dev-python/weasyprint/Manifest3
-rw-r--r--dev-python/weasyprint/files/weasyprint-51-skip-useless-deps.patch30
-rw-r--r--dev-python/weasyprint/weasyprint-53.2.ebuild44
3 files changed, 46 insertions, 31 deletions
diff --git a/dev-python/weasyprint/Manifest b/dev-python/weasyprint/Manifest
index 601e9e3c4b0a..7803a858a7cb 100644
--- a/dev-python/weasyprint/Manifest
+++ b/dev-python/weasyprint/Manifest
@@ -1,4 +1,5 @@
-AUX weasyprint-51-skip-useless-deps.patch 526 BLAKE2B 8e0fc794ffab3b9ba9d9c5992dba9f2ca5d88a3e79018f108558e81556f968498087a13aacd7030677e86000b7ad3f5ecab276dfe53b13b1fd0d3356c597cfd7 SHA512 dad97fd25f9f506aa7806a55b459eff051bb5592e28393733bb5c2c03473a8a93e78116339bd435f8d215e7f297772c9feae68cb84d5d1710bc72a6476cf608a
DIST weasyprint-53.0.tar.gz 386339 BLAKE2B 6d8e30a02d54061557e549a685944de7cbc61f4c1b46b23dbaef66e87232325f630fd5a34cf5c846599612914f9306b5235fad65a008e19a7c200af2f4c7d9da SHA512 de34ee5654ee90aec82b67c1bc7d9496fe3a4247b2a649ab110d1613c4780fd9ae611c9da177de07e5287749978af9a4a7d5c102d0940e5fd970e5aa8586c47e
+DIST weasyprint-53.2.tar.gz 387220 BLAKE2B 820c3ef386c86ab927a02153e68ba085817d18c9658539233c283b2ee2e58a190420a88d3d1b4282d7e46eefbd89d9c5fbd94ccefaa6ef7c304d893579739482 SHA512 c4e1a831a9ac5b3adf1241b8c53c90330e3960cf7a5ab8307bbeb89e8e17a7e5a5d50fd676961ce45deda606b82eaa2b05d37f7dd5a1506bd0d78f8e4276328a
EBUILD weasyprint-53.0.ebuild 1077 BLAKE2B 3921ee1d9975cdb5e384118122fd7416e139138a190178ce5bad6209fb4dc8c67722015816229119438a8a0f85046d83465bba65ee32d7a265e3622f875b3d5b SHA512 9be92a78f9151511482ed4ab7b4fc5d4818416d5d6e0bf5d72bc3d6275f3c6fb6f8d354fb75cf1be88bf1909c315395ebc1e6b1ff8a85f881fd1f2a2619ce19b
+EBUILD weasyprint-53.2.ebuild 1077 BLAKE2B 3921ee1d9975cdb5e384118122fd7416e139138a190178ce5bad6209fb4dc8c67722015816229119438a8a0f85046d83465bba65ee32d7a265e3622f875b3d5b SHA512 9be92a78f9151511482ed4ab7b4fc5d4818416d5d6e0bf5d72bc3d6275f3c6fb6f8d354fb75cf1be88bf1909c315395ebc1e6b1ff8a85f881fd1f2a2619ce19b
MISC metadata.xml 381 BLAKE2B 982845693b3b9c957a8c3ccf4cf8b0dbf05a5bba61415b6a8c48999cb949588156afc573ea03996bba5623668ea294fdd54442ca61e662c309d45bcf73d3ecf0 SHA512 aea55fc47b8f47f1b5d6169bcc111ec6a1b95c3c141e7c585009c6b7f9ae901722df9e188b4185bb15919a98095fa0a45f6a51d12cd9fb24056a33ffd7fcd1c6
diff --git a/dev-python/weasyprint/files/weasyprint-51-skip-useless-deps.patch b/dev-python/weasyprint/files/weasyprint-51-skip-useless-deps.patch
deleted file mode 100644
index 862f11dc0a04..000000000000
--- a/dev-python/weasyprint/files/weasyprint-51-skip-useless-deps.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- a/setup.cfg
-+++ b/setup.cfg
-@@ -40,7 +40,6 @@
- [options]
- packages = find:
- zip_safe = false
--setup_requires = pytest-runner
- install_requires =
- setuptools>=39.2.0
- cffi>=0.6
-@@ -50,11 +49,6 @@
- cssselect2>=0.1
- CairoSVG>=2.4.0
- Pyphen>=0.9.1
--tests_require =
-- pytest-runner
-- pytest-cov
-- pytest-flake8
-- pytest-isort
- python_requires = >= 3.5
-
- [options.entry_points]
-@@ -86,7 +80,6 @@
- test = pytest
-
- [tool:pytest]
--addopts = --flake8 --isort
- norecursedirs = build dist .cache .eggs .git
-
- [coverage:run]
diff --git a/dev-python/weasyprint/weasyprint-53.2.ebuild b/dev-python/weasyprint/weasyprint-53.2.ebuild
new file mode 100644
index 000000000000..f201ef75f8ef
--- /dev/null
+++ b/dev-python/weasyprint/weasyprint-53.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Visual rendering engine for HTML and CSS that can export to PDF"
+HOMEPAGE="https://weasyprint.org https://github.com/Kozea/WeasyPrint"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/cffi-0.6:=[${PYTHON_USEDEP}]
+ >=dev-python/cssselect2-0.1[${PYTHON_USEDEP}]
+ >=dev-python/fonttools-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pillow-4.0.0[jpeg,jpeg2k,${PYTHON_USEDEP}]
+ >=dev-python/pydyf-0.0.3[${PYTHON_USEDEP}]
+ >=dev-python/pyphen-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/tinycss2-1.0.0[${PYTHON_USEDEP}]
+ x11-libs/pango
+"
+
+BDEPEND="
+ test? (
+ app-text/ghostscript-gpl
+ media-fonts/ahem
+ media-fonts/dejavu
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/addopts/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}