summaryrefslogtreecommitdiff
path: root/dev-python/watchfiles/watchfiles-0.21.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/watchfiles/watchfiles-0.21.0-r1.ebuild')
-rw-r--r--dev-python/watchfiles/watchfiles-0.21.0-r1.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-python/watchfiles/watchfiles-0.21.0-r1.ebuild b/dev-python/watchfiles/watchfiles-0.21.0-r1.ebuild
index 6e9298bff633..de7f49819093 100644
--- a/dev-python/watchfiles/watchfiles-0.21.0-r1.ebuild
+++ b/dev-python/watchfiles/watchfiles-0.21.0-r1.ebuild
@@ -112,6 +112,12 @@ src_prepare() {
}
python_test() {
+ local EPYTEST_DESELECT=(
+ # test broken with new anyio
+ # https://github.com/samuelcolvin/watchfiles/issues/254
+ tests/test_watch.py::test_awatch_interrupt_raise
+ )
+
rm -rf watchfiles || die
epytest
}