summaryrefslogtreecommitdiff
path: root/dev-python/wand/wand-0.6.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/wand/wand-0.6.7.ebuild')
-rw-r--r--dev-python/wand/wand-0.6.7.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/wand/wand-0.6.7.ebuild b/dev-python/wand/wand-0.6.7.ebuild
new file mode 100644
index 000000000000..6f133f63eaa4
--- /dev/null
+++ b/dev-python/wand/wand-0.6.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+MY_P="${PN^}-${PV}"
+DESCRIPTION="Ctypes-based simple ImageMagick binding for Python"
+HOMEPAGE="http://wand-py.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="media-gfx/imagemagick"
+BDEPEND="
+ test? (
+ media-gfx/imagemagick[fftw,jpeg,png,truetype,xml]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_test() {
+ # PDF support is blocked by the default ImageMagick security policy
+ epytest --skip-pdf
+}