summaryrefslogtreecommitdiff
path: root/dev-python/vobject/vobject-0.9.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/vobject/vobject-0.9.7.ebuild')
-rw-r--r--dev-python/vobject/vobject-0.9.7.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/vobject/vobject-0.9.7.ebuild b/dev-python/vobject/vobject-0.9.7.ebuild
new file mode 100644
index 000000000000..c59c5f8977a2
--- /dev/null
+++ b/dev-python/vobject/vobject-0.9.7.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python package for parsing and generating vCard and vCalendar files"
+HOMEPAGE="https://eventable.github.io/vobject/
+ https://pypi.org/project/vobject/
+ https://github.com/eventable/vobject"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND=">=dev-python/python-dateutil-2.4.0[${PYTHON_USEDEP}]"
+
+DOCS=( ACKNOWLEDGEMENTS.txt README.md )
+
+distutils_enable_tests unittest