summaryrefslogtreecommitdiff
path: root/dev-python/vdf/vdf-3.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/vdf/vdf-3.3.ebuild')
-rw-r--r--dev-python/vdf/vdf-3.3.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/vdf/vdf-3.3.ebuild b/dev-python/vdf/vdf-3.3.ebuild
new file mode 100644
index 000000000000..573902811712
--- /dev/null
+++ b/dev-python/vdf/vdf-3.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A module for (de)serialization to and from VDF, Valve's key-value text format"
+HOMEPAGE="https://github.com/ValvePython/vdf"
+SRC_URI="https://codeload.github.com/ValvePython/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.2-mock_from_stdlib.patch
+)
+
+distutils_enable_tests pytest