summaryrefslogtreecommitdiff
path: root/dev-python/vcrpy
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/vcrpy')
-rw-r--r--dev-python/vcrpy/Manifest1
-rw-r--r--dev-python/vcrpy/vcrpy-6.0.1-r1.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/vcrpy/Manifest b/dev-python/vcrpy/Manifest
index 0581a8b4fe6e..a99529c6a693 100644
--- a/dev-python/vcrpy/Manifest
+++ b/dev-python/vcrpy/Manifest
@@ -1,4 +1,5 @@
AUX vcrpy-6.0.1-httpbin-compat.patch 1921 BLAKE2B 7ac8e0fa08f38b2b1f3bf78f80485a32d2ca2a56bff4c9c70b42049a6ed37dadd25f25fedd77b578d7452b87bf74825b0bd062186f74c9cc6a7017be6fe189f7 SHA512 81b87869bf8af2b853ff5a336c45ac1b26ed8f49729e2da94859b621d1110a07081d280dfb541fab0a8bb2ad48c26be48a3966f17a7455242da0b150a569c0c8
DIST vcrpy-6.0.1.gh.tar.gz 337497 BLAKE2B a00571d7ed0dd895cc120e3e2615e8e6ea3e86344813e87f836a182be45389b200925ae2a02dc754b0b77db642d3be453b3b8c909b26197222b84fa95c6da804 SHA512 79ba9ea29db20ddc3db5676d7bdb05da17848eb126ed63d813a1d2b0de80573fff3afaec2ffe1af491a0310ce922c7545c4569035d0f5868f171db25965c217f
+EBUILD vcrpy-6.0.1-r1.ebuild 1901 BLAKE2B 4212b480696a3250bf0b485cf588f27c07addc662a1e53e4546af8516892b2f059a1f732174b95ab830156736be6bca07c9097dc673c91baaf5f5ef37bc37b08 SHA512 6beede85e357b3917b5e6c649193b55fc5bfaee8492d841d556fd096c72ba488ce688e64f7cf19d7d899ac1968dd5baccfb3afec6a7987a511d1b888601d5869
EBUILD vcrpy-6.0.1.ebuild 2457 BLAKE2B 8113970483c823cc8b5b91558a970042a83e069cf82f90e567d6189c5e2b85b993dcdcfea282e4f51b31898d05632f2b9941d2085b6dfce04cd6274ba8a0e654 SHA512 d7bf742469fe375e8cf54df94676684e2cad4ffb546a7f68a6b2913d944860305fcb0ef6766281895435c5b290e33c3c63054c7e36addc35b104bc47de437b41
MISC metadata.xml 388 BLAKE2B fd31293bd6085e6a93816a1813a8c3a9d046ed3d932fba5b32b454a71e7535606ba92815699b7ca10fc837b07a5335df54d5fae8c860a7ea88c6ea72891d0620 SHA512 0360ac6f113035ffd1991d2a42000f290c9d0a3fa8c4dac9abfde0eecafd23e1ff9929d8ee521f83a924c523992fabc5cb4353079bf7c52dac9f906a31d4da55
diff --git a/dev-python/vcrpy/vcrpy-6.0.1-r1.ebuild b/dev-python/vcrpy/vcrpy-6.0.1-r1.ebuild
new file mode 100644
index 000000000000..b82fe8880935
--- /dev/null
+++ b/dev-python/vcrpy/vcrpy-6.0.1-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically mock your HTTP interactions to simplify and speed up testing"
+HOMEPAGE="
+ https://github.com/kevin1024/vcrpy/
+ https://pypi.org/project/vcrpy/
+"
+SRC_URI="
+ https://github.com/kevin1024/vcrpy/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.16.2[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/wrapt[${PYTHON_USEDEP}]
+ dev-python/yarl[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/pytest-httpbin-2.0.0-r1[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/kevin1024/vcrpy/pull/823
+ "${FILESDIR}/${P}-httpbin-compat.patch"
+)
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # these tests are failing with recent dev-python/werkzeug; losely related:
+ # https://github.com/kevin1024/vcrpy/issues/645
+ tests/integration/test_record_mode.py::test_new_episodes_record_mode_two_times
+ tests/integration/test_urllib2.py::test_random_body
+ tests/integration/test_urllib2.py::test_multiple_requests
+ # Internet
+ "tests/integration/test_urllib3.py::test_post[https]"
+ )
+
+ local EPYTEST_IGNORE=(
+ # requires boto3
+ tests/integration/test_boto3.py
+ # Internet
+ tests/integration/test_tornado.py
+ tests/integration/test_aiohttp.py
+ )
+
+ local -x REQUESTS_CA_BUNDLE=$("${EPYTHON}" -m pytest_httpbin.certs)
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -m 'not online' -p httpbin -p rerunfailures --reruns=5
+}