summaryrefslogtreecommitdiff
path: root/dev-python/vcrpy/vcrpy-4.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/vcrpy/vcrpy-4.3.0.ebuild')
-rw-r--r--dev-python/vcrpy/vcrpy-4.3.0.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/dev-python/vcrpy/vcrpy-4.3.0.ebuild b/dev-python/vcrpy/vcrpy-4.3.0.ebuild
deleted file mode 100644
index 619447a5d035..000000000000
--- a/dev-python/vcrpy/vcrpy-4.3.0.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Automatically mock your HTTP interactions to simplify and speed up testing"
-HOMEPAGE="
- https://github.com/kevin1024/vcrpy/
- https://pypi.org/project/vcrpy/
-"
-SRC_URI="
- https://github.com/kevin1024/vcrpy/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
-
-# <urllib3-2 for https://github.com/kevin1024/vcrpy/issues/688.
-RDEPEND="
- >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- >=dev-python/six-1.5[${PYTHON_USEDEP}]
- <dev-python/urllib3-2[${PYTHON_USEDEP}]
- dev-python/wrapt[${PYTHON_USEDEP}]
- dev-python/yarl[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-httpbin[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # these tests require Internet
- tests/integration/test_aiohttp.py
- tests/integration/test_boto.py
- tests/integration/test_httplib2.py::test_effective_url
- tests/integration/test_httpx.py
- tests/integration/test_record_mode.py::test_new_episodes_record_mode_two_times
- tests/integration/test_urllib2.py
- tests/integration/test_urllib3.py::test_redirects
- tests/integration/test_wild.py::test_amazon_doctype
- tests/integration/test_wild.py::test_flickr_should_respond_with_200
- tests/unit/test_stubs.py::TestVCRConnection::testing_connect
- )
-
- local -x REQUESTS_CA_BUNDLE=$("${EPYTHON}" -m pytest_httpbin.certs)
- epytest
-}