summaryrefslogtreecommitdiff
path: root/dev-python/urllib3
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/urllib3')
-rw-r--r--dev-python/urllib3/Manifest4
-rw-r--r--dev-python/urllib3/urllib3-1.26.5.ebuild65
-rw-r--r--dev-python/urllib3/urllib3-1.26.6.ebuild2
3 files changed, 2 insertions, 69 deletions
diff --git a/dev-python/urllib3/Manifest b/dev-python/urllib3/Manifest
index cef081279a40..e76697687380 100644
--- a/dev-python/urllib3/Manifest
+++ b/dev-python/urllib3/Manifest
@@ -1,5 +1,3 @@
-DIST urllib3-1.26.5.tar.gz 292865 BLAKE2B 0b22a485635f70f198c022c13d03af2b1a9b6907276e3bc3acaa2242e1c632447762f86e9588e735462e6479ff93a172f458691ea9bf28ceaebd5e1cfbc55501 SHA512 4a1899b223b00894d49f6dff5fc95d410e5b0ab28c11f7e3cd82d03e50438b0c5b0adf693a33fd80f1586312dc0012836713998674da15531bf82d52645881f6
DIST urllib3-1.26.6.tar.gz 289927 BLAKE2B 197b0df759b27fc4906c565426e9c7b533fad56f10695ab5ae6c6c4d05d5c889dba906be526d8b8f41405f29696046b7db6e2cbb2fa16843af80e072138cc35f SHA512 19eb4b88b7a575db717db420ff79b304769d9a6d2b576a236d69719101c4d52d6b0079bd049c885e630f0dfd60471f8bb33836847e0569652cddece910ec2979
-EBUILD urllib3-1.26.5.ebuild 1962 BLAKE2B 619160dfebe98b7497545a2044c4af5522b54d3b53a956c86041bb50588562784feb41c32faaded7feb7769e364029a695decd7a22ecc5c5673a4bba5ece4aa6 SHA512 a54a2e38a40e134c8cf8fab84b99f5a810ae89452a0204ef12ee695b3aa3d616887b6ec3d908447c2f807a258050bd55ecd4a05687f38a7811f82486cf9b454e
-EBUILD urllib3-1.26.6.ebuild 1970 BLAKE2B e3dee58d1f4b280c2c2c8a84afcb9356450f045267ec321467933ffac73a9de5050473524d971cd65724b8de1b3e22ea824fc0cfd933a3083bd46b0b6bbb6dc0 SHA512 4d14b178b5d4df05883498a6cb0b38d1630ba11e20b3d93ccb57a27bf99e0d510389f1344155177501472f4ec4f39d8bf5c4ef4fcb6141a3d0d0e2eed5a86219
+EBUILD urllib3-1.26.6.ebuild 1962 BLAKE2B 1fe2eae1dd3608a8b9f8a6ef3582f92a78a98ac8ba0378561825708f72c2341c8900ab6aa38b88a74fa8b6f0d9421dbee903a93d8b4ee1036f69d0bedebac4a2 SHA512 b265eeadf3bb12270e604cbd65b570c836b081c8b7e67a19aeba8b29b9b62bd93a2cec945bb770b422e354f97675766ed3451630cdc9c5ad6d44523c603d02f8
MISC metadata.xml 530 BLAKE2B 148b6a1936566b905f38f00ec231a832e827bbdd4f6c2ceabe521779b08c1dbf60bdfa182234e8e67b6708efadd09d29e93c151f7c3d1d4fcd5ece3e3d9c0839 SHA512 9ab9fa9ecb34855be0f6e7914f70eadca67854fde865765b1257feec6c841bccd8276ad81f8d9bbfb544ca753c3d27681d6cc841cee008efca5ba72f5a236f3e
diff --git a/dev-python/urllib3/urllib3-1.26.5.ebuild b/dev-python/urllib3/urllib3-1.26.5.ebuild
deleted file mode 100644
index a718303d1a5e..000000000000
--- a/dev-python/urllib3/urllib3-1.26.5.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-PYTHON_REQ_USE="ssl(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP library with thread-safe connection pooling, file post, and more"
-HOMEPAGE="https://github.com/urllib3/urllib3"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="brotli test"
-RESTRICT="!test? ( test )"
-
-# dev-python/{pyopenssl,cryptography,idna,certifi} are optional runtime
-# dependencies. Do not add them to RDEPEND. They should be unnecessary with
-# modern versions of python (>= 3.2).
-RDEPEND="
- >=dev-python/PySocks-1.5.8[${PYTHON_USEDEP}]
- <dev-python/PySocks-2.0[${PYTHON_USEDEP}]
- brotli? ( dev-python/brotlicffi[${PYTHON_USEDEP}] )
-"
-BDEPEND="
- test? (
- $(python_gen_cond_dep "
- ${RDEPEND}
- dev-python/brotlicffi[\${PYTHON_USEDEP}]
- dev-python/mock[\${PYTHON_USEDEP}]
- dev-python/pytest[\${PYTHON_USEDEP}]
- dev-python/pytest-freezegun[\${PYTHON_USEDEP}]
- >=dev-python/trustme-0.5.3[\${PYTHON_USEDEP}]
- >=www-servers/tornado-4.2.1[\${PYTHON_USEDEP}]
- " python3_{6..10})
- )
-"
-
-python_prepare_all() {
- # tests failing if 'localhost.' cannot be resolved
- sed -e 's:test_dotted_fqdn:_&:' \
- -i test/with_dummyserver/test_https.py || die
- sed -e 's:test_request_host_header_ignores_fqdn_dot:_&:' \
- -i test/with_dummyserver/test_socketlevel.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local -x CI=1
- # FIXME: get tornado ported
- # please keep in sync with BDEPEND!
- has "${EPYTHON}" python3.{6..10} || continue
-
- local deselect=(
- # TODO?
- test/with_dummyserver/test_socketlevel.py::TestSocketClosing::test_timeout_errors_cause_retries
- )
-
- epytest ${deselect[@]/#/--deselect }
-}
diff --git a/dev-python/urllib3/urllib3-1.26.6.ebuild b/dev-python/urllib3/urllib3-1.26.6.ebuild
index b68c311d9396..c71c6adc940b 100644
--- a/dev-python/urllib3/urllib3-1.26.6.ebuild
+++ b/dev-python/urllib3/urllib3-1.26.6.ebuild
@@ -14,7 +14,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="brotli test"
RESTRICT="!test? ( test )"