summaryrefslogtreecommitdiff
path: root/dev-python/uritools
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/uritools')
-rw-r--r--dev-python/uritools/Manifest3
-rw-r--r--dev-python/uritools/metadata.xml31
-rw-r--r--dev-python/uritools/uritools-4.0.1.ebuild24
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/uritools/Manifest b/dev-python/uritools/Manifest
new file mode 100644
index 000000000000..8e11ff61ada3
--- /dev/null
+++ b/dev-python/uritools/Manifest
@@ -0,0 +1,3 @@
+DIST uritools-4.0.1.tar.gz 23524 BLAKE2B ca1d0e739436211838df50b1fe7949c5a43f9bf17ec24cf4b5f5748bcb4a330d677134e568a1683422c80a1cc178bd1f4325df7f0e27ac3af09a025fd95513ac SHA512 d616103a74161ed3f2920d2c6aa75cbfc7425940c46097a7b3701d3db3b8771f012bce17dd595d56154fe7ac00527a6bc989810c2e0beb4556e5caa5720e085e
+EBUILD uritools-4.0.1.ebuild 493 BLAKE2B 8b4395bec9dfbe822a0d1fef3f8e1a5c3343c43a867e8f3242a8ce2ab872a7f8c0f60a1c6a0fd6666f74976a1e3d4be30fe66ab8a3e7c1270fc56286c216b4de SHA512 efdbfb09093ecd08ebae63c4fb1b4eb3f5c1d46fcc266c52c66cbf7f30f16ede094fb4d4c160a3e506ff02e62b4727f56f23f710bb037741e5cd61f01814ac94
+MISC metadata.xml 1330 BLAKE2B df7bdf865359417f17c74d9126491e91721d154a465e0d96700a0d5e8eabd8195396ac3948d7e701f918d4e6617101f55b1433903a0e5acdf633a3988be06247 SHA512 99d28ce814dd8714f99344f7fade06559c3ac90cfb2da34d15751ca4b94087b4617fcaf0ff2a54a22f058e4746e4c69b27fe3615c5348e274b0893a9b24d6364
diff --git a/dev-python/uritools/metadata.xml b/dev-python/uritools/metadata.xml
new file mode 100644
index 000000000000..b327baf4c3b1
--- /dev/null
+++ b/dev-python/uritools/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+ For various reasons, ``urllib.parse`` and its Python 2 predecessor
+ ``urlparse`` are not compliant with current Internet standards. As
+ stated in `Lib/urllib/parse.py
+ &lt;https://github.com/python/cpython/blob/3.8/Lib/urllib/parse.py&gt;`_:
+
+ RFC 3986 is considered the current standard and any future changes
+ to urlparse module should conform with it. The urlparse module is
+ currently not entirely compliant with this RFC due to defacto
+ scenarios for parsing, and for backward compatibility purposes,
+ some parsing quirks from older RFCs are retained.
+
+ This module aims to provide fully RFC 3986 compliant replacements for
+ the most commonly used functions found in ``urllib.parse``. It also
+ includes functions for distinguishing between the different forms of
+ URIs and URI references, and for conveniently creating URIs from their
+ individual components.
+ </longdescription>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">uritools</remote-id>
+ <remote-id type="github">tkem/uritools</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/uritools/uritools-4.0.1.ebuild b/dev-python/uritools/uritools-4.0.1.ebuild
new file mode 100644
index 000000000000..3369476d3621
--- /dev/null
+++ b/dev-python/uritools/uritools-4.0.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+DOCS_BUILDER="sphinx"
+PYTHON_COMPAT=( python3_{10..12} )
+
+DOCS_DIR="docs"
+
+inherit distutils-r1 docs pypi
+
+DESCRIPTION="RFC 3986-compliant URI parsing, classification and composition"
+HOMEPAGE="
+ https://github.com/tkem/uritools/
+ https://pypi.org/project/uritools/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+distutils_enable_tests pytest