summaryrefslogtreecommitdiff
path: root/dev-python/unittest2/unittest2-1.1.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/unittest2/unittest2-1.1.0-r1.ebuild')
-rw-r--r--dev-python/unittest2/unittest2-1.1.0-r1.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-python/unittest2/unittest2-1.1.0-r1.ebuild b/dev-python/unittest2/unittest2-1.1.0-r1.ebuild
deleted file mode 100644
index 232865bfcf40..000000000000
--- a/dev-python/unittest2/unittest2-1.1.0-r1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="The new features in unittest backported to Python 2.4+"
-HOMEPAGE="https://pypi.org/project/unittest2/ https://github.com/testing-cabal/unittest-ext"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-
-RDEPEND="
- dev-python/linecache2[${PYTHON_USEDEP}]
- >=dev-python/six-1.4[${PYTHON_USEDEP}]
- dev-python/traceback2[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests unittest
-
-PATCHES=(
- "${FILESDIR}"/remove-argparse-dependence.patch
- "${FILESDIR}"/${P}-python3.5-test.patch
-)
-
-python_test() {
- "${PYTHON}" -m unittest2 discover --verbose ||
- die "tests failed under ${EPYTHON}"
-}