summaryrefslogtreecommitdiff
path: root/dev-python/unittest2/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/unittest2/files')
-rw-r--r--dev-python/unittest2/files/remove-argparse-dependence.patch12
-rw-r--r--dev-python/unittest2/files/unittest2-1.1.0-python3.5-test.patch28
2 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/unittest2/files/remove-argparse-dependence.patch b/dev-python/unittest2/files/remove-argparse-dependence.patch
deleted file mode 100644
index 36f89fc5f8f6..000000000000
--- a/dev-python/unittest2/files/remove-argparse-dependence.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -r 8928fb47c3a9 setup.py
---- a/setup.py Thu Mar 12 15:55:36 2015 +1300
-+++ b/setup.py Sun Apr 05 09:06:44 2015 -0500
-@@ -57,7 +57,7 @@
- # Both install and setup requires - because we read VERSION from within the
- # package, and the package also exports all the APIs.
- # six for compat helpers
--REQUIRES = ['argparse', 'six>=1.4', 'traceback2'],
-+REQUIRES = ['six>=1.4', 'traceback2'],
-
- params = dict(
- name=NAME,
diff --git a/dev-python/unittest2/files/unittest2-1.1.0-python3.5-test.patch b/dev-python/unittest2/files/unittest2-1.1.0-python3.5-test.patch
deleted file mode 100644
index 4aae9d04b2f8..000000000000
--- a/dev-python/unittest2/files/unittest2-1.1.0-python3.5-test.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff --git a/unittest2/test/test_loader.py b/unittest2/test/test_loader.py
-index 683f662..347eea5 100644
---- a/unittest2/test/test_loader.py
-+++ b/unittest2/test/test_loader.py
-@@ -509,6 +509,7 @@ class Test_TestLoader(unittest2.TestCase):
- #
- # What happens when an impossible name is given, relative to the provided
- # `module`?
-+ @unittest.skipIf(sys.version_info[:2] >= (3, 5), "python 3.5 has problems here")
- def test_loadTestsFromName__relative_malformed_name(self):
- loader = unittest.TestLoader()
-
-@@ -811,6 +812,7 @@ class Test_TestLoader(unittest2.TestCase):
- # TestCase or TestSuite instance."
- #
- # What happens when presented with an impossible module name?
-+ @unittest.skipIf(sys.version_info[:2] >= (3, 5), "python 3.5 has problems here")
- def test_loadTestsFromNames__malformed_name(self):
- loader = unittest2.TestLoader()
-
-@@ -918,6 +920,7 @@ class Test_TestLoader(unittest2.TestCase):
- # "The method optionally resolves name relative to the given module"
- #
- # What happens when presented with an impossible attribute name?
-+ @unittest.skipIf(sys.version_info[:2] >= (3, 5), "python 3.5 has problems here")
- def test_loadTestsFromNames__relative_malformed_name(self):
- loader = unittest.TestLoader()
-