summaryrefslogtreecommitdiff
path: root/dev-python/unidecode
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/unidecode')
-rw-r--r--dev-python/unidecode/unidecode-1.1.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/unidecode/unidecode-1.1.1.ebuild b/dev-python/unidecode/unidecode-1.1.1.ebuild
new file mode 100644
index 000000000000..5cdc5ae57905
--- /dev/null
+++ b/dev-python/unidecode/unidecode-1.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{5,6,7}} )
+PYTHON_REQ_USE="wide-unicode(+)"
+
+MY_PN=Unidecode
+MY_P=${MY_PN}-${PV}
+
+inherit distutils-r1
+
+DESCRIPTION="Module providing ASCII transliterations of Unicode text"
+HOMEPAGE="https://pypi.org/project/Unidecode/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+S=${WORKDIR}/${MY_P}
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}