summaryrefslogtreecommitdiff
path: root/dev-python/uncompyle6/uncompyle6-2.10.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/uncompyle6/uncompyle6-2.10.1.ebuild')
-rw-r--r--dev-python/uncompyle6/uncompyle6-2.10.1.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/uncompyle6/uncompyle6-2.10.1.ebuild b/dev-python/uncompyle6/uncompyle6-2.10.1.ebuild
deleted file mode 100644
index f1b9c4531e26..000000000000
--- a/dev-python/uncompyle6/uncompyle6-2.10.1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Python cross-version byte-code deparser"
-HOMEPAGE="https://github.com/rocky/python-uncompyle6/ https://pypi.org/project/uncompyle6/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="
- >=dev-python/xdis-3.3.1
- <dev-python/xdis-3.4.0
- >=dev-python/spark-parser-1.6.1
- <dev-python/spark-parser-1.7.0"
-DEPEND="${RDEPEND}
- test? (
- >=dev-python/nose-1.0[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/hypothesis[${PYTHON_USEDEP}]
- )
-"
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
-}
-
-# only run the recommended "make check" tests
-python_test() {
- distutils_install_for_testing
-
- PYTHONPATH="${S}/test:${BUILD_DIR}/lib" \
- emake check || die "Tests failed under ${EPYTHON}"
-}