summaryrefslogtreecommitdiff
path: root/dev-python/ujson/ujson-4.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ujson/ujson-4.1.0.ebuild')
-rw-r--r--dev-python/ujson/ujson-4.1.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/ujson/ujson-4.1.0.ebuild b/dev-python/ujson/ujson-4.1.0.ebuild
new file mode 100644
index 000000000000..3d2e889a9b9d
--- /dev/null
+++ b/dev-python/ujson/ujson-4.1.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Ultra fast JSON encoder and decoder for Python"
+HOMEPAGE="https://pypi.org/project/ujson/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/pytz[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest