summaryrefslogtreecommitdiff
path: root/dev-python/tzlocal/tzlocal-4.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tzlocal/tzlocal-4.1.ebuild')
-rw-r--r--dev-python/tzlocal/tzlocal-4.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/tzlocal/tzlocal-4.1.ebuild b/dev-python/tzlocal/tzlocal-4.1.ebuild
new file mode 100644
index 000000000000..e052e465a137
--- /dev/null
+++ b/dev-python/tzlocal/tzlocal-4.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="tzinfo object for the local timezone"
+HOMEPAGE="https://github.com/regebro/tzlocal"
+SRC_URI="https://github.com/regebro/tzlocal/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/pytz_deprecation_shim[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/backports-zoneinfo[${PYTHON_USEDEP}]
+ ' python3_8 pypy3)"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest