summaryrefslogtreecommitdiff
path: root/dev-python/typogrify/typogrify-2.0.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/typogrify/typogrify-2.0.7.ebuild')
-rw-r--r--dev-python/typogrify/typogrify-2.0.7.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/typogrify/typogrify-2.0.7.ebuild b/dev-python/typogrify/typogrify-2.0.7.ebuild
new file mode 100644
index 000000000000..9b24bf19f431
--- /dev/null
+++ b/dev-python/typogrify/typogrify-2.0.7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Filters for web typography, supporting Django & Jinja templates"
+HOMEPAGE="https://github.com/mintchaos/typogrify/ https://pypi.org/project/typogrify/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ >=dev-python/smartypants-1.8.3[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest --doctest-modules typogrify/filters.py typogrify/packages/titlecase/tests.py
+}