summaryrefslogtreecommitdiff
path: root/dev-python/tvdb_api/tvdb_api-2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tvdb_api/tvdb_api-2.0.ebuild')
-rw-r--r--dev-python/tvdb_api/tvdb_api-2.0.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/tvdb_api/tvdb_api-2.0.ebuild b/dev-python/tvdb_api/tvdb_api-2.0.ebuild
new file mode 100644
index 000000000000..df8357e712a9
--- /dev/null
+++ b/dev-python/tvdb_api/tvdb_api-2.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="Python interface to thetvdb.com API"
+HOMEPAGE="https://github.com/dbr/tvdb_api"
+SRC_URI="mirror://pypi/t/${PN}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/requests-cache[${PYTHON_USEDEP}]"