summaryrefslogtreecommitdiff
path: root/dev-python/trove-classifiers/trove-classifiers-2022.10.19.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/trove-classifiers/trove-classifiers-2022.10.19.ebuild')
-rw-r--r--dev-python/trove-classifiers/trove-classifiers-2022.10.19.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/trove-classifiers/trove-classifiers-2022.10.19.ebuild b/dev-python/trove-classifiers/trove-classifiers-2022.10.19.ebuild
new file mode 100644
index 000000000000..964617661415
--- /dev/null
+++ b/dev-python/trove-classifiers/trove-classifiers-2022.10.19.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Canonical source for classifiers on PyPI (pypi.org)"
+HOMEPAGE="
+ https://github.com/pypa/trove-classifiers/
+ https://pypi.org/project/trove-classifiers/
+"
+SRC_URI="
+ https://github.com/pypa/trove-classifiers/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/calver[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest
+ "${EPYTHON}" -m tests.lib || die
+}