summaryrefslogtreecommitdiff
path: root/dev-python/trio
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/trio')
-rw-r--r--dev-python/trio/Manifest4
-rw-r--r--dev-python/trio/trio-0.25.0.ebuild67
-rw-r--r--dev-python/trio/trio-0.25.1.ebuild2
3 files changed, 2 insertions, 71 deletions
diff --git a/dev-python/trio/Manifest b/dev-python/trio/Manifest
index 69391d5d03a2..31a3205e04da 100644
--- a/dev-python/trio/Manifest
+++ b/dev-python/trio/Manifest
@@ -1,5 +1,3 @@
-DIST trio-0.25.0.gh.tar.gz 599079 BLAKE2B d0615111fba3981c89d72a6eff93e9f500854e94f7227f3f235d4effa4ab53b9a280278b62db90c4a9612028edc5c9892b56464c9ee5b7e3c8120086dfc64e56 SHA512 0690193c501e054b5c2d96ea208d6a49b9ac860dd63a58c4b5cec5b5f6f197fc5eae0e2fae99ef498d5d1513b189a75504905bd5cc6dc34ae791e3451655933a
DIST trio-0.25.1.gh.tar.gz 600963 BLAKE2B f72df0069ff48f198f7c31221c721ffb127c4cac6c4e004547d62aa5f184673fde09e2baad5c383b206deffec4ef1b04dafad883dad0b2ced2625d72ac842887 SHA512 0a924a1c52ed5153e51cc3343c92b7f6218cf8c56ba2e66b6fe40d27d2acfa7475c3014b8fc5fd22e46df1782530a75f899dbb35d1c875331400957891bd70aa
-EBUILD trio-0.25.0.ebuild 1742 BLAKE2B 4f821136c5e31f4793e12e9355888211c761e3c8e7cb271d07850e421a6231dfb29d32f15064e3c110c70ab05c1ad14f08538cb86604b1007ef9f74870f2ad3d SHA512 fe4807a9245936cdc8b40de43c0da48467310c9882b516768190ae9c395ae2e59eea27488d17e47c9ebc9ee3a8b64dcab8b2a466885c4fa5be22d049d767b458
-EBUILD trio-0.25.1.ebuild 1749 BLAKE2B f7704d67a41e99ba0dfc8a088e0046d9f2bd6cc0a8de64d021e345002009779da17f1a78220b2f61c36161969736146d43edc0b6fe7a3888f55c904382920425 SHA512 65fb7a2f926638bd094239603f3ea724a80ca8528f9ff0ff812101f8d06beb802e19804c44d06d6eb3fc646708b39ad6e81fc108372f1e84f312e6e40b81d017
+EBUILD trio-0.25.1.ebuild 1742 BLAKE2B 4f821136c5e31f4793e12e9355888211c761e3c8e7cb271d07850e421a6231dfb29d32f15064e3c110c70ab05c1ad14f08538cb86604b1007ef9f74870f2ad3d SHA512 fe4807a9245936cdc8b40de43c0da48467310c9882b516768190ae9c395ae2e59eea27488d17e47c9ebc9ee3a8b64dcab8b2a466885c4fa5be22d049d767b458
MISC metadata.xml 2060 BLAKE2B bb6ddfddfb3c19038e5982227a8c5f9999b93868c343a9a5bf7af5963006b5b719ef960f65b91747dfddf19544134db9e1a2d65e94192c079c64c303cdc8997a SHA512 4b86e7cccddc200d5616550e309ad46587f900ed13c38196e874e5110974b856d65e18745b8b7b42858cb672940ba280b0c2ea54d33f9b5bf32a375fa1232088
diff --git a/dev-python/trio/trio-0.25.0.ebuild b/dev-python/trio/trio-0.25.0.ebuild
deleted file mode 100644
index 9a7f71be22f6..000000000000
--- a/dev-python/trio/trio-0.25.0.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library for async concurrency and I/O"
-HOMEPAGE="
- https://github.com/python-trio/trio/
- https://pypi.org/project/trio/
-"
-SRC_URI="
- https://github.com/python-trio/${PN}/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="|| ( Apache-2.0 MIT )"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/attrs-23.2.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/exceptiongroup[${PYTHON_USEDEP}]
- ' 3.10)
- dev-python/idna[${PYTHON_USEDEP}]
- dev-python/outcome[${PYTHON_USEDEP}]
- >=dev-python/sniffio-1.3.0[${PYTHON_USEDEP}]
- dev-python/sortedcontainers[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- >=dev-python/astor-0.8.0[${PYTHON_USEDEP}]
- >=dev-python/immutables-0.6[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/trustme[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-# Bug https://bugs.gentoo.org/916756
-# distutils_enable_sphinx docs/source \
-# dev-python/immutables \
-# dev-python/sphinxcontrib-trio \
-# dev-python/sphinx-rtd-theme \
-# dev-python/towncrier
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Times out on slower arches (ia64 in this case)
- # https://github.com/python-trio/trio/issues/1753
- tests/test_unix_pipes.py::test_close_at_bad_time_for_send_all
- # requires ruff
- _tests/tools/test_gen_exports.py
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- rm -rf trio || die
- epytest -p trio._tests.pytest_plugin \
- -m "not redistributors_should_skip" \
- --pyargs trio \
- --skip-optional-imports
-}
diff --git a/dev-python/trio/trio-0.25.1.ebuild b/dev-python/trio/trio-0.25.1.ebuild
index 01f9924188d7..9a7f71be22f6 100644
--- a/dev-python/trio/trio-0.25.1.ebuild
+++ b/dev-python/trio/trio-0.25.1.ebuild
@@ -20,7 +20,7 @@ SRC_URI="
LICENSE="|| ( Apache-2.0 MIT )"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="amd64 arm arm64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
RDEPEND="
>=dev-python/attrs-23.2.0[${PYTHON_USEDEP}]