summaryrefslogtreecommitdiff
path: root/dev-python/trio
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/trio')
-rw-r--r--dev-python/trio/Manifest4
-rw-r--r--dev-python/trio/trio-0.26.2.ebuild67
-rw-r--r--dev-python/trio/trio-0.27.0.ebuild2
3 files changed, 2 insertions, 71 deletions
diff --git a/dev-python/trio/Manifest b/dev-python/trio/Manifest
index 76b5f153fdc0..4027021ee6e7 100644
--- a/dev-python/trio/Manifest
+++ b/dev-python/trio/Manifest
@@ -1,5 +1,3 @@
-DIST trio-0.26.2.gh.tar.gz 610516 BLAKE2B dfb62a4024f2e42243dff6bea97ee3657c1975ff8d081010efe1b0fd3962a3b1c4847341df1028e2c902a043d0b43b6190ccdd72d5bfdb6e650912034ee56c28 SHA512 0b6fda127937de5c13eb12aea4ad5f95b4bfcb839c1a65c25a563aef6450bfb35c24af3509043eb389472e414549fbc9d40e64c8aff068cb34ffaf8b29fe9c67
DIST trio-0.27.0.gh.tar.gz 617781 BLAKE2B 343e7e351c34cfa6176d9ae46ad2c4311793f47b8032713efbdc5ed1d152552260002a59b8e02e256a8241a32a9d21505f4354340bcca88a62ca16e8dc5c8a01 SHA512 10fb7b14a7dcccc7a8f04793a1c6992449bd9934726f5a2648fde2533a33cb38468ecd0de8f098544174d51046400bae32b435ed432085cf4d631c9feef88058
-EBUILD trio-0.26.2.ebuild 1750 BLAKE2B 6ab9bba94af5a7ca9fd499781d61c35540593668476ae7a6491aad954ec011eb0d3ba10a66d1038ec3b940dcac7027372de3dd8f112268cd4bbdd427e1145046 SHA512 305326aba005a7b09fc727db6d529b45487dbf2b93803a5c7dfa5dedb9f74d47cec8bb04ec3547c170480412f2fa2d40ac277a871ff4d527a86775d1f994fc72
-EBUILD trio-0.27.0.ebuild 1757 BLAKE2B c9354d0d68f61919d0c0303a4f589cddfb89749f5f878b443efd588de9973fc603b1e9068e2924f1d23b0bdb13c98039a4782def2066094fd5b8dc35adcce9ae SHA512 ad74bda9a451180e4d6aacd87761b7f16e39e49388cc41902ed00bd454a324eed697f08cf5300c66fdfcf14a391a531000a7631a4d5834d1ae74e31ef81f3660
+EBUILD trio-0.27.0.ebuild 1750 BLAKE2B 6ab9bba94af5a7ca9fd499781d61c35540593668476ae7a6491aad954ec011eb0d3ba10a66d1038ec3b940dcac7027372de3dd8f112268cd4bbdd427e1145046 SHA512 305326aba005a7b09fc727db6d529b45487dbf2b93803a5c7dfa5dedb9f74d47cec8bb04ec3547c170480412f2fa2d40ac277a871ff4d527a86775d1f994fc72
MISC metadata.xml 2060 BLAKE2B bb6ddfddfb3c19038e5982227a8c5f9999b93868c343a9a5bf7af5963006b5b719ef960f65b91747dfddf19544134db9e1a2d65e94192c079c64c303cdc8997a SHA512 4b86e7cccddc200d5616550e309ad46587f900ed13c38196e874e5110974b856d65e18745b8b7b42858cb672940ba280b0c2ea54d33f9b5bf32a375fa1232088
diff --git a/dev-python/trio/trio-0.26.2.ebuild b/dev-python/trio/trio-0.26.2.ebuild
deleted file mode 100644
index d7a0315ad2ad..000000000000
--- a/dev-python/trio/trio-0.26.2.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library for async concurrency and I/O"
-HOMEPAGE="
- https://github.com/python-trio/trio/
- https://pypi.org/project/trio/
-"
-SRC_URI="
- https://github.com/python-trio/${PN}/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="|| ( Apache-2.0 MIT )"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/attrs-23.2.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/exceptiongroup-1.2.1[${PYTHON_USEDEP}]
- ' 3.10)
- dev-python/idna[${PYTHON_USEDEP}]
- dev-python/outcome[${PYTHON_USEDEP}]
- >=dev-python/sniffio-1.3.0[${PYTHON_USEDEP}]
- dev-python/sortedcontainers[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- >=dev-python/astor-0.8.0[${PYTHON_USEDEP}]
- >=dev-python/immutables-0.6[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/trustme[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-# Bug https://bugs.gentoo.org/916756
-# distutils_enable_sphinx docs/source \
-# dev-python/immutables \
-# dev-python/sphinxcontrib-trio \
-# dev-python/sphinx-rtd-theme \
-# dev-python/towncrier
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Times out on slower arches (ia64 in this case)
- # https://github.com/python-trio/trio/issues/1753
- tests/test_unix_pipes.py::test_close_at_bad_time_for_send_all
- # requires ruff
- _tests/tools/test_gen_exports.py
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- rm -rf trio || die
- epytest -p trio._tests.pytest_plugin \
- -m "not redistributors_should_skip" \
- --pyargs trio \
- --skip-optional-imports
-}
diff --git a/dev-python/trio/trio-0.27.0.ebuild b/dev-python/trio/trio-0.27.0.ebuild
index 01b349cf4ec8..d7a0315ad2ad 100644
--- a/dev-python/trio/trio-0.27.0.ebuild
+++ b/dev-python/trio/trio-0.27.0.ebuild
@@ -20,7 +20,7 @@ SRC_URI="
LICENSE="|| ( Apache-2.0 MIT )"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="amd64 arm arm64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
RDEPEND="
>=dev-python/attrs-23.2.0[${PYTHON_USEDEP}]