summaryrefslogtreecommitdiff
path: root/dev-python/trimesh
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/trimesh')
-rw-r--r--dev-python/trimesh/Manifest2
-rw-r--r--dev-python/trimesh/trimesh-4.6.5.ebuild79
2 files changed, 81 insertions, 0 deletions
diff --git a/dev-python/trimesh/Manifest b/dev-python/trimesh/Manifest
index d43461b7b1c9..00424142a89d 100644
--- a/dev-python/trimesh/Manifest
+++ b/dev-python/trimesh/Manifest
@@ -1,3 +1,5 @@
DIST trimesh-4.6.4.gh.tar.gz 13624427 BLAKE2B b61caf9a08f219bd0dc7f6f55262dd798d3ce7c56e7a9daf3486365ec8b035b19c63f1d99ddc68ecfa9e940480e2f4307229a4fb8371e75a583f5cf8d9c29db0 SHA512 2f52ea216d448fbab32938f905137df6aac593f88343672e0e93a808f2dfece8eb477e82185c0d1150245742f2c4bb4be8c704757e428cba87f528dc1ebdb3d7
+DIST trimesh-4.6.5.gh.tar.gz 13625081 BLAKE2B 81c5527ad7cdb1dc78b61a3bfbf2fb3ff6e3b412050b77fdf249a1af7b4be9aacb3bdc19331cc334803eee998be0e5390c3282d400598aa5be3b41fd701ed3f9 SHA512 b1fc5de064fd06c3bf453e507ff6c3e14dcfb2c8d1d909b4a3c2bc2e894e2aac57342b85c0d170b0a161f3ae27b9ca2490df601fb047c1873703cb71ce97f1fa
EBUILD trimesh-4.6.4.ebuild 2183 BLAKE2B 1ba86db229b0a155cb01e1c255074d39ce695ae94cd6cbd70028edf2850e5a8ef9b2f2e81142a368f27d0129c40c88ccf8b087ad74838ff5019e3a3dd1feacbd SHA512 4a59cf64aab849c8c919551129ab943c599d2a6191de7e54223393dc34fde7f6bb5768c3753fd8cad6bed1538200b07654a13f20378f0fb3d48ad3e9f7376bf0
+EBUILD trimesh-4.6.5.ebuild 2185 BLAKE2B c604e438cc9ca47cc4c088c0126afe1f2736d399ca99ade28970f44951168d71ace351d9bc19016d94a04e79e6692c0ac951f5587a64621db414fa6176393fdd SHA512 7f1c51e048fdbbee8173cee7d66c2f0acc87687592d0343430b11901c8f6e18c0091090dd6a0f59b1375f46e95c4ee06ed3dd92bdbe0052fc8038feee86431c0
MISC metadata.xml 389 BLAKE2B 6dcc92dfafdedb5cc7fe5f40977594114bbf1628d8179d7222c3b60c4a591e236c7a937530006beb9649a8a84636bcb1923d8ad6a377994295f85b1fe8eb8bbd SHA512 a96f4fb6a1c2bd820f2dd072230fa160536834e1ef19483c372571df2d082cb5a63434181af9107022b75e1019d369d6bece8262eb752cedf24a5038e15ea473
diff --git a/dev-python/trimesh/trimesh-4.6.5.ebuild b/dev-python/trimesh/trimesh-4.6.5.ebuild
new file mode 100644
index 000000000000..252b04a9f06e
--- /dev/null
+++ b/dev-python/trimesh/trimesh-4.6.5.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for loading and using triangular meshes"
+HOMEPAGE="
+ https://trimesh.org/
+ https://github.com/mikedh/trimesh/
+ https://pypi.org/project/trimesh/
+"
+SRC_URI="
+ https://github.com/mikedh/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/charset-normalizer[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.20[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycollada[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ >=dev-python/shapely-1.8.2[${PYTHON_USEDEP}]
+ dev-python/svg-path[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ dev-python/rtree[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mapbox-earcut[${PYTHON_USEDEP}]
+ dev-python/pillow[webp,${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_TIMEOUT=1800
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires manifold3d
+ tests/test_boolean.py::test_multiple_difference
+ # timing nonsense
+ tests/test_bounds.py::BoundsTest::test_obb_mesh_large
+ )
+ local EPYTEST_IGNORE=(
+ # require pyinstrument
+ tests/test_sweep.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} functionality can be extended by installing the following packages:"
+ optfeature "making GUI applications with 3D stuff" dev-python/glooey
+ optfeature "2D triangulations of polygons" dev-python/mapbox-earcut
+ optfeature "loading a number of additional mesh formats" dev-python/meshio
+ optfeature "figuring out how much memory we have" dev-python/psutil
+ optfeature "marching cubes and other nice stuff" dev-python/scikit-image
+}