summaryrefslogtreecommitdiff
path: root/dev-python/tree-sitter/tree-sitter-0.19.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tree-sitter/tree-sitter-0.19.0.ebuild')
-rw-r--r--dev-python/tree-sitter/tree-sitter-0.19.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/tree-sitter/tree-sitter-0.19.0.ebuild b/dev-python/tree-sitter/tree-sitter-0.19.0.ebuild
new file mode 100644
index 000000000000..db8a7bdabd25
--- /dev/null
+++ b/dev-python/tree-sitter/tree-sitter-0.19.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+MY_PN=${PN/-/_}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python bindings to the Tree-sitter parsing library"
+HOMEPAGE="https://github.com/tree-sitter/py-tree-sitter"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> py-${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+
+S="${WORKDIR}/${MY_P}"