summaryrefslogtreecommitdiff
path: root/dev-python/translate-toolkit
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/translate-toolkit')
-rw-r--r--dev-python/translate-toolkit/Manifest2
-rw-r--r--dev-python/translate-toolkit/translate-toolkit-3.14.8.ebuild119
2 files changed, 121 insertions, 0 deletions
diff --git a/dev-python/translate-toolkit/Manifest b/dev-python/translate-toolkit/Manifest
index f5bcfb3f1c73..b1a96c1325c9 100644
--- a/dev-python/translate-toolkit/Manifest
+++ b/dev-python/translate-toolkit/Manifest
@@ -1,5 +1,7 @@
DIST translate-3.14.6.gh.tar.gz 1175486 BLAKE2B 3cfd844815adcd7ac24a41df41f3e717d7afa7c19f4e4467f9ce7892ec9adb321ed2e499358cdaa294c5a5d8ca8e20271ac47cc598b8e7585c290eea8e9b8235 SHA512 a2e23c4ec29e61fdcc0c28e7789478d595a11751c6117b7b5cc9191deec01e31309cea8a6e39c81635105b8b6b10c34533af5b91b736f7c2bbd4780146b79b3d
DIST translate-3.14.7.gh.tar.gz 1176117 BLAKE2B 4237e99c92b1e0e207e4618039061ff33170d1e152d224b2455514f7a30a7248566304e8550bb3f8a7412daf26f50c855541c3d0674d4f9e032e65d9d5e12eec SHA512 e0b505a0d5cd520a83560e08aa414a3b3d95b4c7af96a7dd3cd5a7e28ff827918e12cbefa36212b018a1ab7c2c345d6fb66e94d5d09f80eaa6bcaf330c5927e8
+DIST translate-3.14.8.gh.tar.gz 1177211 BLAKE2B 70e57918899f77057f4f42af2e9aab0df180b788b4f8e22a081cc607d8ee2e34264ba0715e23ede85ffb8882c579b3d6c61cd247756cbdbb54fd8a92f44a838d SHA512 5ff3f56e44f171f2c6bc1c3bf82787cc7f024615fb0d1371a11e8135a2908150ec515b40beaf3a3deeaeefa6c4ea2345ce4766ebe9b3d188d5cabfd762b9ed30
EBUILD translate-toolkit-3.14.6.ebuild 3179 BLAKE2B 7823612c89199b9c055e1d8bad2ec83f38196a9a8ec67a24f638a55b0bb5e0207b61f889c13fdae41634ff50c8e4f9994fc330aa2d9b0014b60f72e4f4970fe8 SHA512 b0e3a3795b4190b62c0ad2a73f399331ff3371e05eb820ada00b3f87efd8488a31c7dcdb3fe955be9ebd5840bfc5c7e6b41c7a5fada20b9698aa94874c60f08a
EBUILD translate-toolkit-3.14.7.ebuild 3182 BLAKE2B 132ece55534f73a3628579ccbdaf1b49ba1a59f3d84b5e015c2b0f277c005db79fe3009f568dc78b6b184ed4dcc0bd6f4be5a1ee62c75d3eff424d446d81a88a SHA512 75e13d61a98635ad89257c8979403298df7fc33df50f2bfc598b8db07e39648fa4120c08e4bf881bc79538d042d876d80411d10feaa2981e6a193cd63b450b56
+EBUILD translate-toolkit-3.14.8.ebuild 3182 BLAKE2B 132ece55534f73a3628579ccbdaf1b49ba1a59f3d84b5e015c2b0f277c005db79fe3009f568dc78b6b184ed4dcc0bd6f4be5a1ee62c75d3eff424d446d81a88a SHA512 75e13d61a98635ad89257c8979403298df7fc33df50f2bfc598b8db07e39648fa4120c08e4bf881bc79538d042d876d80411d10feaa2981e6a193cd63b450b56
MISC metadata.xml 756 BLAKE2B 06f64f258d362954f99f7e9eee241eb3dddc6b00b9069df2ad977d28b5cf06f9c8ee2246ee5958600b5ac86297968d7aaced6b6420dca4ed507c441c58c61ca9 SHA512 80374c40513ca450f97e3930929c1450e7438ea15830e60937952a6fccfd999675f2ca2056c5aa4e287ba256c6ec08a09d8f7adb8b2c5af8ca0cd595f34acd85
diff --git a/dev-python/translate-toolkit/translate-toolkit-3.14.8.ebuild b/dev-python/translate-toolkit/translate-toolkit-3.14.8.ebuild
new file mode 100644
index 000000000000..9af4d0313f20
--- /dev/null
+++ b/dev-python/translate-toolkit/translate-toolkit-3.14.8.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+MY_P=translate-${PV}
+DESCRIPTION="Toolkit to convert between many translation formats"
+HOMEPAGE="
+ https://github.com/translate/translate/
+ https://pypi.org/project/translate-toolkit/
+"
+SRC_URI="
+ https://github.com/translate/translate/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+html +ical +ini +subtitles +yaml"
+
+RDEPEND="
+ app-text/iso-codes
+ >=dev-python/chardet-3.0.4[${PYTHON_USEDEP}]
+ dev-python/cheroot[${PYTHON_USEDEP}]
+ >=dev-python/levenshtein-0.12.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/mistletoe-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-3[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ >=dev-python/cwcwidth-0.1.9[${PYTHON_USEDEP}]
+ sys-devel/gettext
+ html? ( dev-python/utidylib[${PYTHON_USEDEP}] )
+ ical? ( dev-python/vobject[${PYTHON_USEDEP}] )
+ ini? ( >=dev-python/iniparse-0.5[${PYTHON_USEDEP}] )
+ subtitles? ( media-video/gaupol[${PYTHON_USEDEP}] )
+ yaml? ( dev-python/pyyaml[${PYTHON_USEDEP}] )
+"
+# Technically, the test suite also has undeclared dependency
+# on dev-python/snapshottest but all the tests using it are broken
+# anyway, so we skip them.
+BDEPEND="
+ test? (
+ dev-python/phply[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ # unfortunately, this bad quality package doesn't support XDG_DATA_DIRS
+ # correctly, so we need to reassemble all data files in a single directory
+ local -x XDG_DATA_HOME=${T}/share
+ cp -r translate/share "${T}/" || die
+ cp -r "${ESYSROOT}/usr/share"/gaupol "${XDG_DATA_HOME}"/ || die
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Fails with network-sandbox (and even with it off but w/ softer fail)
+ 'tests/xliff_conformance/test_xliff_conformance.py::test_open_office_to_xliff'
+ 'tests/xliff_conformance/test_xliff_conformance.py::test_po_to_xliff'
+ # all tests based on snapshottest are broken and I'm too tired
+ # to figure this out
+ tests/translate/tools/test_pocount.py::test_{cases,output}
+ tests/translate/tools/test_junitmsgfmt.py::test_output
+ )
+ local EPYTEST_IGNORE=(
+ # unpackaged fluent.*
+ tests/translate/storage/test_fluent.py
+ # changes directory and does not change it back, sigh
+ tests/odf_xliff/test_odf_xliff.py
+ )
+
+ if ! use ini; then
+ EPYTEST_IGNORE+=(
+ translate/convert/test_ini2po.py
+ translate/convert/test_po2ini.py
+ )
+ fi
+
+ if ! use subtitles; then
+ EPYTEST_IGNORE+=(
+ translate/storage/test_subtitles.py
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /usr
+ doins -r translate/share
+
+ if ! use html; then
+ rm "${ED}"/usr/bin/{html2po,po2html} || die
+ fi
+ if ! use ical; then
+ rm "${ED}"/usr/bin/{ical2po,po2ical} || die
+ fi
+ if ! use ini; then
+ rm "${ED}"/usr/bin/{ini2po,po2ini} || die
+ fi
+ if ! use subtitles; then
+ rm "${ED}"/usr/bin/{sub2po,po2sub} || die
+ fi
+}