summaryrefslogtreecommitdiff
path: root/dev-python/transitions/transitions-0.8.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/transitions/transitions-0.8.11.ebuild')
-rw-r--r--dev-python/transitions/transitions-0.8.11.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/transitions/transitions-0.8.11.ebuild b/dev-python/transitions/transitions-0.8.11.ebuild
deleted file mode 100644
index b809687c46ad..000000000000
--- a/dev-python/transitions/transitions-0.8.11.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="A lightweight, object-oriented state machine implementation in Python"
-HOMEPAGE="https://github.com/pytransitions/transitions"
-SRC_URI="https://github.com/pytransitions/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="examples"
-
-RDEPEND="
- || (
- dev-python/pygraphviz[${PYTHON_USEDEP}]
- dev-python/graphviz[${PYTHON_USEDEP}]
- )
- dev-python/six[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? (
- dev-python/dill[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pycodestyle[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_install() {
- distutils-r1_src_install
- use examples && dodoc examples/*.ipynb
-}