summaryrefslogtreecommitdiff
path: root/dev-python/traitlets/traitlets-5.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/traitlets/traitlets-5.1.0.ebuild')
-rw-r--r--dev-python/traitlets/traitlets-5.1.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/traitlets/traitlets-5.1.0.ebuild b/dev-python/traitlets/traitlets-5.1.0.ebuild
new file mode 100644
index 000000000000..cc6e4c002e4e
--- /dev/null
+++ b/dev-python/traitlets/traitlets-5.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="A configuration system for Python applications"
+HOMEPAGE="https://github.com/ipython/traitlets"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+PATCHES=(
+ "${FILESDIR}/${P}-py310.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ dev-python/ipython_genutils \
+ dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest