summaryrefslogtreecommitdiff
path: root/dev-python/tqdm
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tqdm')
-rw-r--r--dev-python/tqdm/Manifest4
-rw-r--r--dev-python/tqdm/tqdm-4.66.6.ebuild45
-rw-r--r--dev-python/tqdm/tqdm-4.67.0.ebuild45
3 files changed, 94 insertions, 0 deletions
diff --git a/dev-python/tqdm/Manifest b/dev-python/tqdm/Manifest
index 8527735a5b83..e7a6b6f91a4d 100644
--- a/dev-python/tqdm/Manifest
+++ b/dev-python/tqdm/Manifest
@@ -1,3 +1,7 @@
DIST tqdm-4.66.5.tar.gz 169504 BLAKE2B 9868bcfb4f3fc22aedfbb848d383055ef6ef9795982cd7877e620dba5391ffee369c375b27555c302d1fc6fb27ddacf8d3874daeffa62e5e8699e1124fbf96af SHA512 8e2c35f02fe365063a325d8a1d3e525870d522fab465e1a86764b8716ff32c039db463fe5e74a5f080ced40851d49b1e4273126074d62f14ed1935a96e0afb8a
+DIST tqdm-4.66.6.tar.gz 169533 BLAKE2B 98f5e357cdd99b45e30345f4a8a7b935de987b301686c2efcbf88813967258ca09ce26d9b3df31a3606db87cb7fdc6a525e8ea44d05d2730709dfeea55c32ad7 SHA512 4813fc6896bde582cb14dac2fd741772c181fe0647197d84d65561e9c9e6bf02b5370658e4839fb8f50c8ad0b8bf0ca5b5ad62b5ea29d912f288d86699b2ff5c
+DIST tqdm-4.67.0.tar.gz 169739 BLAKE2B e596b4a8e1c9af1b21f55dbf8f96ae716d4a28700fdeeddd7073f0ee73429e745d3e69824f9d53d258e646fdc84228c7407a432fbf00a6fd5651eb3fe62136fb SHA512 87c9f233eb28ff1570fc8b9a5a55c19b116b8dd451d82f1bfb14ca8bf8a2c3135fe9b788476c301ca169ef2c32099945178907feebdb4129eac2558d205e5715
EBUILD tqdm-4.66.5.ebuild 995 BLAKE2B b7b08fdd2fb188d978b0747646a2f3928f9afb85c2e2c53a790fa7c59fd5328c42ae5ce886a06af7375f80bfa2f19d634861c3fd4376c77976cff74ee242b307 SHA512 c836918a9fe4b59426e8285a61d6f231b9987cedcb0f37e1c05a3440003961480e004da970f902635e328aca87bdc7674a0407e644fc58521e1a540a00f0e84d
+EBUILD tqdm-4.66.6.ebuild 1003 BLAKE2B 5bdf4e0623e59a51754727fd8fd45e79b9a1beaafa700d0f07f94487df6ad76f3f9e10434f2ec555a529abf950348fe08cff3a7dd9fa096024a1349403bc3ea8 SHA512 41b2435706dd7227fd99b3e8d8a26e02f851d10288885a55a905a8248bf110f5ecba0763320d995da8da4f7eca358722aa6802a0dd5d434814aa028ca7789886
+EBUILD tqdm-4.67.0.ebuild 1003 BLAKE2B 5bdf4e0623e59a51754727fd8fd45e79b9a1beaafa700d0f07f94487df6ad76f3f9e10434f2ec555a529abf950348fe08cff3a7dd9fa096024a1349403bc3ea8 SHA512 41b2435706dd7227fd99b3e8d8a26e02f851d10288885a55a905a8248bf110f5ecba0763320d995da8da4f7eca358722aa6802a0dd5d434814aa028ca7789886
MISC metadata.xml 605 BLAKE2B ed20e6f11f20cdc6525b98d9fd37c0b8f0781dd1c4be85e8aa4a3f5644a20fde3179bd44bb99ef4c14913168113a58963b36281ccf4807a694624a1e2df578f8 SHA512 b5f096a0256312e6ab5098bb6d9965b567bd735813d9c97fa49f08de640f2c5ebb292ba747eb284ff043dc29d4bb1cab1ac947ecaab6b4e94aa51e96a0cac636
diff --git a/dev-python/tqdm/tqdm-4.66.6.ebuild b/dev-python/tqdm/tqdm-4.66.6.ebuild
new file mode 100644
index 000000000000..134307285bc4
--- /dev/null
+++ b/dev-python/tqdm/tqdm-4.66.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1 pypi
+
+DESCRIPTION="Add a progress meter to your loops in a second"
+HOMEPAGE="
+ https://github.com/tqdm/tqdm/
+ https://pypi.org/project/tqdm/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+IUSE="examples"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Skip unpredictable performance tests
+ tests/tests_perf.py
+)
+
+python_install_all() {
+ doman tqdm/tqdm.1
+ newbashcomp tqdm/completion.sh tqdm
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/tqdm/tqdm-4.67.0.ebuild b/dev-python/tqdm/tqdm-4.67.0.ebuild
new file mode 100644
index 000000000000..134307285bc4
--- /dev/null
+++ b/dev-python/tqdm/tqdm-4.67.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1 pypi
+
+DESCRIPTION="Add a progress meter to your loops in a second"
+HOMEPAGE="
+ https://github.com/tqdm/tqdm/
+ https://pypi.org/project/tqdm/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+IUSE="examples"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Skip unpredictable performance tests
+ tests/tests_perf.py
+)
+
+python_install_all() {
+ doman tqdm/tqdm.1
+ newbashcomp tqdm/completion.sh tqdm
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}