summaryrefslogtreecommitdiff
path: root/dev-python/torment/torment-3.0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/torment/torment-3.0.3.ebuild')
-rw-r--r--dev-python/torment/torment-3.0.3.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/torment/torment-3.0.3.ebuild b/dev-python/torment/torment-3.0.3.ebuild
deleted file mode 100644
index 27d964344340..000000000000
--- a/dev-python/torment/torment-3.0.3.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python3_{5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="A Study in Fixture Based Testing Frameworking"
-HOMEPAGE="https://github.com/kumoru/torment"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc test"
-
-CDEPEND="dev-python/mypy[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
- )
- test? (
- ${CDEPEND}
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="${CDEPEND}"
-
-python_compile_all() {
- use doc && esetup.py build_sphinx
-}
-
-python_test() {
- nosetests || die "Tests failed on ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
-
- distutils-r1_python_install_all
-}