summaryrefslogtreecommitdiff
path: root/dev-python/toposort/toposort-1.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/toposort/toposort-1.8.ebuild')
-rw-r--r--dev-python/toposort/toposort-1.8.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/toposort/toposort-1.8.ebuild b/dev-python/toposort/toposort-1.8.ebuild
new file mode 100644
index 000000000000..93680abc0927
--- /dev/null
+++ b/dev-python/toposort/toposort-1.8.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements a topological sort algorithm"
+HOMEPAGE="
+ https://gitlab.com/ericvsmith/toposort/
+ https://pypi.org/project/toposort/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+python_test() {
+ "${EPYTHON}" test/test_toposort.py -v || die "Tests failed with ${EPYTHON}"
+}