summaryrefslogtreecommitdiff
path: root/dev-python/tomlkit
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tomlkit')
-rw-r--r--dev-python/tomlkit/Manifest5
-rw-r--r--dev-python/tomlkit/files/tomlkit-0.12.5-py313.patch71
-rw-r--r--dev-python/tomlkit/tomlkit-0.12.5-r1.ebuild53
-rw-r--r--dev-python/tomlkit/tomlkit-0.13.0.ebuild2
4 files changed, 2 insertions, 129 deletions
diff --git a/dev-python/tomlkit/Manifest b/dev-python/tomlkit/Manifest
index 1b9660571791..f2995e53df26 100644
--- a/dev-python/tomlkit/Manifest
+++ b/dev-python/tomlkit/Manifest
@@ -1,6 +1,3 @@
-AUX tomlkit-0.12.5-py313.patch 2155 BLAKE2B b7e58a1d24f69a03a9d96a6351079cda82f95eb427103b6d268f2791507925b040b06f33a547644a07a0bb60c89420cf9b332c744dfa4af931b59f6d237216fe SHA512 df4c7f7f46baa75bf0872e0358e56b151db0bc7c61520f2087f589fa38a276f19c006a57520fa0ee145098339cbde4cfc7dd71a5c6c640fcd86814e01649685b
-DIST tomlkit-0.12.5.tar.gz 191420 BLAKE2B 3175f2932db1da3aca439581c7a11fd2dce01dff3c9d21b07577bdf38138515105939bc864510dce1f98e28caa222b6ba94a0d0906b515e7b677c405b90bf77c SHA512 85fba0018059c72f483251e53c039ede4ed630dd31afc58a1555705281a42c090aee2d8c25234b8700ff5f3a766313d7c9c716d7224f608f22f836c9e701c251
DIST tomlkit-0.13.0.tar.gz 191792 BLAKE2B f5f865b49f9850281d01de2c2ba9c2d8685a10a5cd0f17c475d120978472485a5bd607dc4b283221eab69fc6e214259feafdbe85c8237fe9c80b49007523bb69 SHA512 46c5a771ff401e0b300dbd13708d78b63415653b87eb649898bf0bd58cedeb110622ff2f0ade0ad1cd517610229ba0f59b4d520cf2fa1eea6522ea0bc042317e
-EBUILD tomlkit-0.12.5-r1.ebuild 1144 BLAKE2B 28ae13458f979dae624f169b9a34fa6c3589a61eaa94fad401c76e98917fb2581b42037f30fae53100b7c9c174988ca414f5f09375f7fa6a0bf3de6e262246a3 SHA512 634d4e0c00e8efb9879e728d1410079a6b36f394633dac31a8c93aaed4d74a5d3d347fa2b2db1dc5632e81ad4a9ec89f6297df3c1542e3957a1186b5c23113f5
-EBUILD tomlkit-0.13.0.ebuild 1054 BLAKE2B ff9edeb9b6ac424f11db0f96820af6b62dd605d9e1a0051c0763b007d779621b4b35336733e696c5d19e0b079b99e41a92e7272a0dc571200b2720470a4c7d21 SHA512 96d7aca710467357b6217936b4bdb854b02379713e2cc9cf15fcb2cc06c132f27631cc8c7a01d1c1d0ba3c991573e74c84ec85d2feb474ff0a66f5e36638eed2
+EBUILD tomlkit-0.13.0.ebuild 1046 BLAKE2B 6b5bb8be3c8fe0b8acf6d1920a6a3f4c789096f260c1ec5b43b5413529d04efcc9d199d3116014376306e61b15ddf3ea61825ec224692245c1be84bbcffd2cbb SHA512 3d45e510ca0f796c7ddee13cda4be2cf2d5edc2581cb48504117a6bc2d48e8ace8538c99e389f491371d954bec80b31891d80dab2a324c0a760e0fb4d567586c
MISC metadata.xml 529 BLAKE2B 313663d81102b8124a7ebbe11e18003c4714e26daf97ce180c1690b147d750bebfe23af9d894f87ae218148cfb59c3405b25b1736d65fef16bcff4466e026e76 SHA512 f2bab5270eb7346e5de28ed96fb51ded6956ed57724d2ffba6f94b288699ef8107b78155c7c350321e11955c05967d6320444005725c3beedb711cc585f8fa41
diff --git a/dev-python/tomlkit/files/tomlkit-0.12.5-py313.patch b/dev-python/tomlkit/files/tomlkit-0.12.5-py313.patch
deleted file mode 100644
index bc6201d42101..000000000000
--- a/dev-python/tomlkit/files/tomlkit-0.12.5-py313.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-From 05d9be1c2b2a95a4eb3a53d999f1483dd7abae5a Mon Sep 17 00:00:00 2001
-From: Frost Ming <me@frostming.com>
-Date: Mon, 13 May 2024 10:44:28 +0800
-Subject: [PATCH] fix: Test failures with Python 3.13.0a4:
- test_dates_behave_like_dates and test_times_behave_like_times (#349)
-
-Fixes #333
-
-Signed-off-by: Frost Ming <me@frostming.com>
----
- tests/test_items.py | 4 ++--
- tomlkit/items.py | 15 ++++++++++-----
- 4 files changed, 20 insertions(+), 8 deletions(-)
-
-diff --git a/tests/test_items.py b/tests/test_items.py
-index 1a71b04..3d2de68 100644
---- a/tests/test_items.py
-+++ b/tests/test_items.py
-@@ -689,7 +689,7 @@ def test_dates_behave_like_dates():
- assert i.as_string() == "2018-07-22"
-
- i += timedelta(days=1)
-- assert i == datetime(2018, 7, 23)
-+ assert i == date(2018, 7, 23)
- assert i.as_string() == "2018-07-23"
-
- i -= timedelta(days=2)
-@@ -697,7 +697,7 @@ def test_dates_behave_like_dates():
- assert i.as_string() == "2018-07-21"
-
- i = i.replace(year=2019)
-- assert i == datetime(2019, 7, 21)
-+ assert i == date(2019, 7, 21)
- assert i.as_string() == "2019-07-21"
-
- doc = parse("dt = 2018-07-22 # Comment")
-diff --git a/tomlkit/items.py b/tomlkit/items.py
-index ef40a15..661e09c 100644
---- a/tomlkit/items.py
-+++ b/tomlkit/items.py
-@@ -958,9 +958,14 @@ def __new__(cls, year: int, month: int, day: int, *_: Any) -> date:
- return date.__new__(cls, year, month, day)
-
- def __init__(
-- self, year: int, month: int, day: int, trivia: Trivia, raw: str
-+ self,
-+ year: int,
-+ month: int,
-+ day: int,
-+ trivia: Trivia | None = None,
-+ raw: str = "",
- ) -> None:
-- super().__init__(trivia)
-+ super().__init__(trivia or Trivia())
-
- self._raw = raw
-
-@@ -1033,10 +1038,10 @@ def __init__(
- second: int,
- microsecond: int,
- tzinfo: tzinfo | None,
-- trivia: Trivia,
-- raw: str,
-+ trivia: Trivia | None = None,
-+ raw: str = "",
- ) -> None:
-- super().__init__(trivia)
-+ super().__init__(trivia or Trivia())
-
- self._raw = raw
-
diff --git a/dev-python/tomlkit/tomlkit-0.12.5-r1.ebuild b/dev-python/tomlkit/tomlkit-0.12.5-r1.ebuild
deleted file mode 100644
index 02e277f65e3d..000000000000
--- a/dev-python/tomlkit/tomlkit-0.12.5-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Style preserving TOML library"
-HOMEPAGE="
- https://github.com/python-poetry/tomlkit/
- https://pypi.org/project/tomlkit/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-BDEPEND="
- test? (
- dev-python/pyyaml[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- # https://github.com/python-poetry/tomlkit/pull/349
- "${FILESDIR}/${P}-py313.patch"
-)
-
-src_configure() {
- grep -q 'build-backend = "poetry' pyproject.toml ||
- die "Upstream changed build-backend, recheck"
- # write a custom pyproject.toml to ease setuptools bootstrap
- cat > pyproject.toml <<-EOF || die
- [build-system]
- requires = ["flit_core >=3.2,<4"]
- build-backend = "flit_core.buildapi"
-
- [project]
- name = "tomlkit"
- version = "${PV}"
- description = "Style preserving TOML library"
- EOF
-}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}
diff --git a/dev-python/tomlkit/tomlkit-0.13.0.ebuild b/dev-python/tomlkit/tomlkit-0.13.0.ebuild
index 32ec3c8a18ae..6b58c7cec345 100644
--- a/dev-python/tomlkit/tomlkit-0.13.0.ebuild
+++ b/dev-python/tomlkit/tomlkit-0.13.0.ebuild
@@ -16,7 +16,7 @@ HOMEPAGE="
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
BDEPEND="
test? (