summaryrefslogtreecommitdiff
path: root/dev-python/tomlkit/tomlkit-0.11.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tomlkit/tomlkit-0.11.1.ebuild')
-rw-r--r--dev-python/tomlkit/tomlkit-0.11.1.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/tomlkit/tomlkit-0.11.1.ebuild b/dev-python/tomlkit/tomlkit-0.11.1.ebuild
deleted file mode 100644
index ae58bab0c59b..000000000000
--- a/dev-python/tomlkit/tomlkit-0.11.1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Style preserving TOML library"
-HOMEPAGE="
- https://github.com/sdispater/tomlkit/
- https://pypi.org/project/tomlkit/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-BDEPEND="
- test? (
- dev-python/pyyaml[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_configure() {
- # use setup.py to avoid circular dep with poetry-core
- cat > pyproject.toml <<-EOF || die
- [build-system]
- requires = ["setuptools"]
- build-backend = "setuptools.build_meta"
- EOF
-}