summaryrefslogtreecommitdiff
path: root/dev-python/tomli/tomli-1.0.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tomli/tomli-1.0.4.ebuild')
-rw-r--r--dev-python/tomli/tomli-1.0.4.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-python/tomli/tomli-1.0.4.ebuild b/dev-python/tomli/tomli-1.0.4.ebuild
index b35f22cf0cf9..7ad7d69a48f2 100644
--- a/dev-python/tomli/tomli-1.0.4.ebuild
+++ b/dev-python/tomli/tomli-1.0.4.ebuild
@@ -3,7 +3,6 @@
EAPI=8
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
@@ -23,3 +22,13 @@ BDEPEND="
test? ( dev-python/python-dateutil[${PYTHON_USEDEP}] )"
distutils_enable_tests pytest
+
+src_prepare() {
+ # we don't use pyproject.toml to avoid circular deps
+ cat > setup.py <<-EOF || die
+ from setuptools import setup
+ setup(name="tomli", version="${PV}", packages=["tomli"], package_data={"": ["*"]})
+ EOF
+
+ distutils-r1_src_prepare
+}