summaryrefslogtreecommitdiff
path: root/dev-python/tomli-w/tomli-w-0.4.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tomli-w/tomli-w-0.4.0.ebuild')
-rw-r--r--dev-python/tomli-w/tomli-w-0.4.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/tomli-w/tomli-w-0.4.0.ebuild b/dev-python/tomli-w/tomli-w-0.4.0.ebuild
new file mode 100644
index 000000000000..04615adae4a9
--- /dev/null
+++ b/dev-python/tomli-w/tomli-w-0.4.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A lil' TOML writer"
+HOMEPAGE="
+ https://pypi.org/project/tomli-w/
+ https://github.com/hukkin/tomli-w/"
+SRC_URI="
+ https://github.com/hukkin/tomli-w/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? ( dev-python/tomli[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest