summaryrefslogtreecommitdiff
path: root/dev-python/tldextract/tldextract-3.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tldextract/tldextract-3.1.1.ebuild')
-rw-r--r--dev-python/tldextract/tldextract-3.1.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/tldextract/tldextract-3.1.1.ebuild b/dev-python/tldextract/tldextract-3.1.1.ebuild
new file mode 100644
index 000000000000..fe0c1f271c53
--- /dev/null
+++ b/dev-python/tldextract/tldextract-3.1.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Accurately separate the TLD from the registered domain and subdomains of a URL."
+HOMEPAGE="https://pypi.org/project/tldextract/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-file[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--pylint::' pytest.ini || die
+ distutils-r1_src_prepare
+}